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CHAPTER 1:

Overview

INTRODUCTION TO GALAXY
Galaxy is a universal patch librarian that
you can configure to work with any supported MIDI device.
With Galaxy you can:
•

•

•
•

Store patches for any supported MIDI
device. You can store patches in one
of three ways:
1. in device-sized Banks.
2. in Libraries of unlimited size.
3. in Bundles of related patch Banks.
Attach keywords to a patch, then
search any or all Banks and Libraries
for patches with the same keywords.
Search for patches by name or by
attached comments.
Form a dynamic communication link
with OMS 2.0-compatible programs.
The patch names you store in Galaxy
Bundles can be automatically displayed in these applications. For
example, if you alter a patch name in
Galaxy, OMS 2.0 automatically
updates the name in any compatible
applications.

Galaxy Manual

•

Add additional Librarian modules as
they become available. These modules can be either Opcode-created
modules, or modules you create
using Galaxy’s PatchTalk™ language.

If you own Opcode’s Galaxy Plus Editors
program, you can create and edit your
own patches using graphic edit windows.
Editor modules “plug in” to Galaxy Plus
Editors and are available for many
popular MIDI devices.

USING THE GALAXY MANUAL
This manual assumes that you are familiar with basic Macintosh operations. If
you’re not, please read the Macintosh
manual. In particular, you should be comfortable with clicking, double-clicking,
dragging, choosing, selecting, scrolling,
windows, and pop-up menus.
You’ll find it helpful to have a fundamental
understanding of MIDI. If you’re completely new to MIDI, please consider
purchasing an introductory MIDI book
from your local bookstore or music
dealer.
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Galaxy uses Opcode’s Open Music
System (OMS) to communicate with all
your MIDI hardware. If you have never
used OMS, please read your OMS documentation before attempting to use
Galaxy. You must create an OMS Studio
Setup document prior to using Galaxy.

•

This manual is divided into six parts:
•

•

•

•

•

4

PART 1: Getting Started with
Galaxy
This part includes this introductory
chapter and additional chapters on
installation and setup, and Galaxy
terminology.
PART 2: Banks, Bundles, and
Libraries
This part teaches you how to use all
of Galaxy’s storage methods including Banks, Bundles, and Libraries.
PART 3: Auditioning, Cataloging,
and Finding Patches
This part discusses how to audition
patches from within Galaxy, and how
to use Galaxy’s built-in database features to catalog and find patches.
PART 4: Menu Reference
This part discusses every Galaxy
menu command. Each chapter discusses a different Galaxy menu.
PART 5: Galaxy Plus Editors
This part teaches you how to install
and use editor modules with Galaxy
Plus Editors. You must own Opcode’s
Galaxy Plus Editors program to use
graphic editors. If you would like to
upgrade from Galaxy to Galaxy Plus

Editors, please contact Opcode’s Customer Service department as
discussed in Contacting Opcode
(pg. 6).
PART 6: Appendix
This part contains miscellaneous
Galaxy information such as a list of
keywords, a glossary, and instructions on using Galaxy with other
OMS 2.0-compatible applications.

MANUAL CONVENTIONS
This manual uses a number of conventions that make it easier to discuss and
understand certain on-screen actions.

Mouse Actions
This manual uses the following terms to
describe various mouse actions:
•

•

•

Click: When the manual instructs
you to click, position the mouse
where you’re told and press once on
the mouse button, then immediately
release it.
Double-click: When the manual
instructs you to double-click, position
the mouse where you’re told and rapidly press and release the mouse
button twice.
Press and hold: When the manual
instructs you to press and hold, position the mouse where you’re told,
press the mouse button and hold it
down until instructed to release it.

Opcode Systems, Inc.
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•

•

•

Release: When the manual instructs
you to release, let up on the mouse
button (which you were holding
down because of an earlier press and
hold instruction).
Drag: When the manual instructs you
to drag, position the mouse where
you’re told, then press the mouse
button and hold it down as you move
the mouse, releasing the button when
you’re finished.
Move: When the manual instructs
you to move the mouse, simply move
it to another location on the screen
without pressing its button.

Menu Commands
This manual uses a form of verbal shorthand to describe how to choose or select
various menu items. For instance, this
manual might say:
“Select Play>Send MIDI To>Vision.”
What this means in plain english is “select
the Vision option from the Play menu’s
Send MIDI To submenu.” Although the
shorthand technique results in sub-standard grammar, it’s easier to read and
decipher than a complete sentence
because it displays the menu’s hierarchical structure plainly and simply.

Choose vs. Select
The words “choose” and “select” are often
interchangeable in conversational
english. In this manual, however, there is
a distinct difference between the two
terms.
•

•

Select: When the manual tells you to
select something, it stays selected.
This is the case with most menu
options.
Choose: When the manual tells you
to choose something, a one-time
action is performed. This is the case
with most commands; they perform
their chosen action only once.

Galaxy Manual

Figure 1.1: Shorthand Invocation of Menu Items
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SYSTEM REQUIREMENTS

CONTACTING OPCODE

To see the latest Galaxy system requirements, see your Quick Start Card or
review Galaxy’s Read Me file.

You may contact Opcode in the following
ways for technical support, ordering software and upgrades, and requesting or
downloading Technical Publications:

REGISTERING GALAXY
Be sure to send Opcode your Registration
Card—it’s your ticket to:
•
•

•

Free technical support.
Opcode’s periodic newsletter, which
contains advanced tips, troubleshooting techniques, and more.
Information about upgrades,
updates, and new products.

Please write down your Galaxy serial
number exactly as it appears on the label
of your Installer disk. Opcode needs to
know your serial number before helping
you.
S/N

World Wide Web (WWW)
You may access the Opcode Web page at
the following address:
http://www.opcode.com
Follow the instructions in the Web page
to receive the services you desire.

Internet
You may address technical support questions to:
support@opcode.com.

Mail

Date

You may write to Opcode at:
Opcode Systems, Inc.
3950 Fabian Way, Suite 100
Palo Alto, CA 94303

6
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Phone and Fax
For information about Opcode products,
Opcode Technical Publications, or software upgrades, contact Customer Service
at:
(415) 856-3333
For technical information and help using
Opcode products, contact the Technical
Support Department at:

tacting Opcode (pg. 6) to learn where to
download or order Technical
Publications.

Galaxy Editor Modules
Each Editor Module has its own Technical Publication that discusses how to use
that specific Editor. You need to read only
the Technical Publications for the Editor
Modules that you use.

(415) 856-3331
Please try to find the answer in this
manual before calling for Technical
Support.
The Customer Service and Technical Support phone hours are:
Mon - Fri: 9:00 a.m. to 5:00 p.m.
Sat.: 11 a.m. to 5:00 p.m. (with limited
staff support)
You may also contact Opcode by fax:

Opcode may write additional Galaxy
Technical Publications in the future.

UPGRADING TO GALAXY PLUS
EDITORS
If you purchased Galaxy, you can upgrade
to Galaxy Plus Editors. Enclosed in the
Galaxy package is an upgrade form.
Upgrade orders cannot be processed
without your master disk serial number.

(415) 856-0777
NOTE: Technical support hours are subject
to change.

GALAXY TECHNICAL
PUBLICATIONS
In a continuing effort to improve its documentation, Opcode occasionally creates
Technical Publications for its various
hardware and software products. Technical Publications contain information about
a single, specific subject that may not be
of interest to the average user. See Con-

Galaxy Manual
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Installation & Setup

INSTALLING OMS
You must install OMS before you can use
Galaxy. Also, you must create a current
OMS Studio Setup document. See the
Galaxy Quickstart card for installation
instructions and your OMS manual for
details.

THE GALAXY PACKAGE
The Galaxy package contains a number of
800K double-sided disks, the OMS manual, the Galaxy and Galaxy Plus Editors
manual, a Galaxy Quickstart card, and a
registration card. Galaxy is also included
with the Vision and Studio Vision
packages.

Locked

Unlocked

Figure 2.1: Locking/unlocking a disk

The Galaxy master disk included in this
package is copy protected. It’s the only
master disk you have, so take good care
of it. After installing Galaxy, you should
lock your disks so they can’t be altered.
Refer to Figure 2.1 for locking/unlocking
disks.

Galaxy Manual
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INSTALLING GALAXY

•

To install Galaxy, refer to the Galaxy
Quickstart card in the Galaxy Package for
complete instructions.

Installed Galaxy Files and Folders
After installation, your hard disk will contain a Galaxy folder with the following
Galaxy files and folders:
•
•

•

•

10

Galaxy—The application itself.
Galaxy Librarian Modules—Each
module gives Galaxy Librarian capabilities for a specific MIDI device.
Galaxy Editors—Each Editor gives
Galaxy Plus Editors graphic editing
capabilities for a specific MIDI
device. You must own Opcode’s
Galaxy Plus Editors program (not
Galaxy), in order to use editor
modules.
Galaxy Extras—This folder contains
patch utilities for the Yamaha TX81Z
and Korg M1 that convert from a preGalaxy Patch Librarian format to the
current Galaxy format.
PatchTalk Manual: If you’re a programmer and Galaxy doesn’t include
a Librarian for the device you use,
read the Patch Talk documents to
learn how to design your own Galaxy
Librarian Modules. The tools necessary to use PatchTalk are located in
the Programming Tools folder.

•

Patches—This folder contains
patches and utilities for specific
devices:
The Factory Patches with Keywords
folder contains factory patches for ten
major synthesizers. These patches
have keywords attached to them;
they’re intended to help you learn to
use Galaxy’s Find feature.
Sound Source Demo Patches is a collection of patch files for the
Proteus 1/XR, Roland D20, D50, D70;
Kawai K1 & K4 ; Korg M1 and T
series; Yamaha SY/TG 77, TX81Z.
Protologic Factory Presets—These
patches are provided because, due to
their location in ROM, they can not
be accessed through Galaxy’s
normal methods of patch transfer.
Readme—This file contains any additions or corrections to the Galaxy and
Galaxy Plus Editors Manual.

INSTALLING LIBRARIAN AND
EDITOR MODULES
The following sections discuss how to
install Librarian Modules into Galaxy and
Editor Modules into Galaxy Plus Editors.

Librarian Modules
Galaxy can store patches for many different MIDI devices. The Galaxy application
provides a consistent program environment into which you install specific
Librarian Modules. Because Galaxy is a

Opcode Systems, Inc.
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“shell” for Librarian Modules, you cannot
outgrow it—as new MIDI devices become
available, Opcode will create new Librarian Modules that “plug in” to the Galaxy
application.
To use Galaxy, you need to install Librarian Modules for each type of MIDI device
in your studio.

Module Installation Basics
There are three ways to install both
Librarian and Editor Modules.
•
•

When you install a Librarian Module,
Galaxy installs it into the Galaxy Librarian
Modules file, which is at the top level of
your System folder.

•

NOTE: This DOES NOT happen as a
result of the automatic installation of the
program and associated files.

•

Automatic Installation—installs both
Librarian and Editor Modules
Drag and Drop Installation—works
for both Librarian and Editor
Modules
Galaxy Configuration—installs only
Librarian Modules

The method you use depends on:
how your OMS Studio Setup document is configured

The following sections discuss each
installation technique in detail.

Editor Modules
IMPORTANT: In order to use Editor Modules, you must own Galaxy Plus Editors
and have the corresponding Librarian
installed. If you wish to upgrade from
Galaxy to Galaxy Plus Editors, please contact Opcode’s Customer Service department
as discussed in Contacting Opcode (pg. 6).
Besides providing a “shell” for Librarian
Modules, Galaxy Plus Editors also provides a framework for Editor Modules.
You can use Editor Modules to graphically edit the parameters of any supported
MIDI devices.

Automatic Installation
After the Galaxy installation, your hard
disk contains (among other items) two
folders:
•
•

Galaxy Librarians—contains all
Galaxy Librarian Modules.
Galaxy Editors—contains all Galaxy
Editor Modules.

Editor Modules are stored in the Galaxy
Editors folder, which is located in the
same folder as the Galaxy Plus Editors
application.

Galaxy Manual
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To perform an automatic Librarian installation, the Preferences option Auto-Scan/
Install Librarians must be checked (it is
checked by default). For more information

about automatic installation for Librarian
Modules, see Preferences (pg. 110) and
read the Auto-Scan/Install Librarians
section. To allow Galaxy to perform automatic Librarian installation:
a Double-click the Galaxy icon to
launch Galaxy.

Figure 2.2: Galaxy Icon

Galaxy looks at your OMS Studio Setup
document to see what MIDI devices
you’re using. It then loads Librarian Modules for each supported device.

IMPORTANT: To use this Librarian installation method, your OMS Studio Setup
document must define MIDI devices by
device name (Proteus/1), not by serial
port name (modem, printer).
EDITOR USERS: No further action is necessary, since Galaxy uses the Editor
Modules installed in the Galaxy Editors
folder.

Automatic Librarian Updating
OMS automatically notifies Galaxy any
time you change your OMS Studio Setup
document. When Galaxy receives this
notification, it automatically updates the
Galaxy Librarian Modules file to include
the modules needed to support your current Studio Setup document.
This is very beneficial if you frequently
change OMS Studio Setup documents.
NOTE: In order for automatic updating to
work, all Galaxy Librarian Modules must
be in the Galaxy Librarians folder, which
must be in the same folder as the Galaxy
application. Also, the Auto-Scan/Install
Librarians option must be checked.

Drag and Drop Librarian
Installation
You can always use standard “drag-anddrop” techniques to install Librarian Modules into Galaxy. Your hard disk contains
a folder named Galaxy Librarians, which
contains all Galaxy Librarian Modules.
Simply drag-and-drop the desired Librarian icon from this folder onto the Galaxy
icon:

Figure 2.3: Drag and Drop Librarian Installation

12
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Galaxy installs the Librarian module into
Galaxy and updates the Galaxy Librarian Modules file in your System Folder.
EDITOR USERS: You can use the same
technique to install Editor Modules into
Galaxy Plus Editors. In addition, you can
simply drag Editor Modules into the Galaxy
Editors folder.

Galaxy Configuration

Figure 2.4: Galaxy Configuration Dialog Box

You can always use the Galaxy Configuration method to install Librarian Modules
into Galaxy.

NOTE: To learn about this dialog box in
depth, see About the Galaxy Configuration Dialog Box (pg. 110). For now...

EDITOR USERS: This method DOES
NOT install Editor Modules into Galaxy
Plus Editors. Use one of the other installation techniques.

c Click the Install Device button.
Galaxy opens the Installation Dialog
Box.

To install Librarian Modules using the
Galaxy Configuration method:
a If you haven’t already done so,
double-click the Galaxy icon to launch
Galaxy.

b Choose Setups>Galaxy
Configuration.
Galaxy opens the Galaxy Configuration
dialog box.
Figure 2.5: Installation Dialog Box

d Use the upper list to select the
Librarian Module you wish to install.
Your hard disk contains a folder named
Galaxy Librarians, which contains all
Galaxy Librarian Modules.

Galaxy Manual
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e Once you’ve selected the Librarian
Module you wish to install, click the
Add to List button.
Galaxy adds the Librarian Module to the
bottom list.

f Continue selecting desired Librarian
Modules in the upper list and adding
them to the lower list.

g When the bottom list contains the
names of all the Librarian Modules
you wish to install, click the Install
List button.
Galaxy installs the Librarian Modules
into Galaxy and updates the Galaxy
Librarian Modules file in your
System Folder.
Galaxy closes the Installation dialog box
and displays the Galaxy Configuration
dialog box, which now contains all the
newly installed devices in its scrolling
list.

h Click the Exit button.

c Click the Remove button.
Galaxy asks if you’re positive that you
want to remove the Librarian Module for
the selected device.

d Click the Proceed button.
Galaxy removes the Librarian Module for
the selected device.

NOTE: To quickly remove ALL Librarian
modules, drag the Galaxy Librarian
Modules file into the trash.

HARDWARE CONNECTIONS
Galaxy requires two-way communication
with your MIDI device. This means that
Galaxy must be able to send MIDI data to
your MIDI device as well as receive
MIDI data from the device. To do this,
you must connect both the MIDI IN and
MIDI OUT ports on your MIDI device to
your Macintosh MIDI interface.

REMOVING LIBRARIAN
MODULES
To remove Librarian Modules:
a Choose Setups>Galaxy
Configuration.
Galaxy opens the Galaxy Configuration
dialog box.

b Make sure the Devices radio button
is checked.
In the scrolling list, select the device you
wish to remove.

14
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Connecting a Single MIDI Device
The simplest MIDI studios contain a Macintosh, a single port standard MIDI
interface, and a MIDI keyboard.
Figure 2.6 illustrates a very simple MIDI
studio containing a Kurzweil K2000 synthesizer, a standard MIDI interface, and a
Macintosh.

MIDI OUT ports to your standard MIDI
interface as shown in Figure 2.7. Additionally, you would connect your K2000’s
MIDI IN port to one of the MIDI OUT
ports on the interface.
MACINTOSH

STANDARD
MIDI
INTERFACE

MIDI
OUT

MIDI
OUT

MIDI
OUT

MIDI
IN

MACINTOSH

STANDARD
MIDI
INTERFACE

MIDI
OUT

MIDI
OUT

MIDI
OUT

IN OUT

MIDI IN

IN OUT

Emu Proteus/1

Kurzweil K2000
IN

OUT

Kurzweil K2000

Figure 2.7: Multiple MIDI Devices

Figure 2.6: Simple MIDI Studio

In this example, Galaxy can “get” patches
from the K2000 through the cable connected to the K2000’s MIDI OUT port,
and it can “send” patches to the K2000
through the cable connected to the
K2000’s MIDI IN port.

Connecting Two or More MIDI
Devices
Things get a little more involved if your
MIDI studio contains more than one
MIDI sound module, as illustrated by the
following example:
Assume you have two MIDI devices: a
K2000 keyboard synthesizer and a Proteus/1 MIDI sound module, and that
you’re using Galaxy with the Proteus. You
would connect the Proteus’ MIDI IN and

Galaxy Manual

Obviously, the problem with this arrangement is that you can’t play your MIDI
keyboard to audition patches in your Proteus (since there’s no cable connected to
the K2000’s MIDI OUT port). The following sections discuss some of the many
solutions to this problem.
Software Solutions
The first set of solutions are all supported
by the Galaxy application. These techniques are discussed in detail in
Chapter 10: Auditioning Patches.
•

•

•

You can use your Macintosh keyboard to audition sounds on your
Proteus.
You can use Galaxy’s MouseKeys
Window to audition sounds on your
Proteus.
You can create a Galaxy sequence to
use for auditioning sounds on your
Proteus.
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Simple Hardware Solutions
There are also a couple of simple hardware solutions:
•

•

You can reconnect MIDI cables as
necessary. For instance you could
“get” a Bank of patches using the connection shown in Figure 2.7, then
unplug the cable from the Proteus
MIDI OUT port and plug it into the
K2000’s MIDI OUT port to audition
the Proteus sounds.
You can use two MIDI interfaces (one
on each port) or a dual port MIDI
interface (like Opcode’s Translator
ProSync or Studio 3).
MACINTOSH

STANDARD
2-PORT MIDI
INTERFACE

MIDI
OUT

MIDI
IN

IN OUT

Emu Proteus/1

MIDI
OUT

MIDI
IN

IN OUT

Kurzweil K2000

Figure 2.8: MIDI Studio with Dual Port
Standard Interface

Advanced Solutions
You also have a few advanced solutions:
•

•
•
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You can use an external MIDI merger
to merge the MIDI outputs from both
devices.
You can use an external MIDI
patcher.
You can use a multi-port interface
(like Opcode’s Studio 4 or Studio 5).
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CHAPTER 3:

Galaxy Terminology

This chapter discusses important Galaxy
terminology. You will need to understand
these terms before you continue with the
Galaxy manual. The discussions contained in this chapter are very general and
you can study them while seated away
from the computer.

Finally, manufacturers began to build synthesizers with multiple types of patches
and, consequently, multiple types of
banks. Most modern synthesizers now
contain multiple patch types and multiple
banks. Figure 3.1 shows a fictitious,
generic, multiple patch type synthesizer.
MIDI Device

UNDERSTANDING
SYNTHESIZER PATCH
HIERARCHY
Early synthesizers had no on-board memory, thus they contained only one patch
composed of the settings used to create
the sound.
Manufacturers began building synthesizers with an internal memory bank that
allowed the user to store multiple patches
in the device.

Effect Patch Bank

Single Patch Bank

Multi Patch Bank

Figure 3.1: Anatomy of a Generic Multitimbral
Synthesizer

Each synthesizer has a unique hierarchical structure—in other words, the
arrangement in which one type of patch
refers to another type of patch. Figure 3.2
shows a simple, generic patch hierarchy
for our fictitious synthesizer. Notice that
one MultiPatch is made up of numerous
Single Patches and an Effect Patch.
Multi Patch

Single Patch

Single Patch

Single Patch

Effect Patch

Figure 3.2: Generic MIDI Device Patch Hierarchy

Galaxy Manual
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Storing Banks in Bundles

UNDERSTANDING GALAXY
PATCH HIERARCHY
Galaxy gives you many ways to store all
the various synthesizer patches used by
modern MIDI devices.

Storing Patches in Banks
The simplest arrangement (though the
least flexible), is to save banks of synthesizer patches directly into Galaxy Banks.
In this arrangement, each synthesizer
Bank has a matching Galaxy Bank. You
simply send individual patch Banks back
and forth between Galaxy and your MIDI
device. Figure 3.3 illustrates this arrangement graphically (using the generic synth
shown in Figure 3.1 on page 17).

The best way to work with devices that
contain more than one patch type is to use
Galaxy Bundles. Bundles group any or all
related patch Banks into one big file. In
this arrangement, you can transfer all
related patches between Galaxy and your
MIDI device with a single action.
Figure 3.4 illustrates this arrangement
graphically (using the generic synth
shown in Figure 3.1 on page 17).
MIDI Device
Effect Patch Bank

Single Patch Bank

Multi Patch Bank

Bundle 1

Effect Bank 1

Single Bank 1

Multi Bank 1

MIDI Device
Effect Patch Bank

Single Patch Bank

Multi Patch Bank

Effect Bank 1

Single Bank 1

Multi Bank 1

Effect Bank 2

Single Bank 2

Multi Bank 2

Effect Bank 2

Single Bank 3

Multi Bank 3

ETC.

ETC.

ETC.

Bundle 2

Effect Bank 2

Single Bank 2

Multi Bank 2

ETC.
Galaxy

Figure 3.4: Using Galaxy Bundles

Galaxy

Figure 3.3: Using Galaxy Banks
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Storing Many Devices in a Bundle
You can also create Bundles that store
patches for multiple devices as shown in
Figure 3.5.
MIDI Device 1

MIDI Device 2

MIDI Device 3

Bundle

Galaxy

Figure 3.5: Bundle with Many Devices

This feature is particularly useful if:
•

•

You’re performing live and need to
send entire sets of related patches to
all your MIDI devices.
You’re in the studio and need to send
the correct sounds to all the synthesizers in the studio.

Generally, you should think of a Library
as a central storage location for all
patches of a particular type. You can audition individual patches in the Library, and
you can use the Library to select patches
for making Banks.
Assume, for example, that you have hundreds of “Single Patches” for the generic
synthesizer shown in Figure 3.1 on
page 17. Rather than keeping dozens of
patch Banks, you might like to keep all
the patches together in a Library. Similarly, you might like to keep Effects
patches and MultiPatches in their own
libraries as shown in Figure 3.6.
MIDI Device
Effect Patch Bank

Single Patch Bank

Multi Patch Bank

Effect Library

Single Library

Multi Library

Galaxy

Figure 3.6: Using Galaxy Libraries

Storing Patches in a Library
You may find it convenient to keep many
patches of a single type in one central
location. This location is called a Library.
Libraries differ from Banks in the following ways:
•
•

Libraries hold an infinite number of
patches.
You can only send patches from a
Library to your MIDI device one-at-atime.

Galaxy Manual

You can then assemble custom Banks and
Bundles by copying patches from the
Library.

Attached Patches
In Figure 3.2 on page 17, notice that one
MultiPatch is made up of numerous
Single Patches and an Effect Patch. Obviously, if you store a stand-alone Bank (or
Library) or MultiPatches, Galaxy needs
some way to reference the Single Patches
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and Effect Patches that make up the
MultiPatch. In Galaxy terminology, the
MultiPatch is called a parent patch, and
the Single and Effect Patches are called
child patches.
Galaxy provides the capability of “attaching” child patches to parent patches if you
first save all the patch types in a Bundle.
Then, if you copy a parent patch from a
Bundle into either a stand-alone Bank or
Library, Galaxy also copies their child
patches and “attaches” them to the parent
patch as if they were part of the parent
patch. If you copy a parent patch to
another stand-alone Bank or Library, its
child patches are copied with it.
When Galaxy sends a parent patch to a
synthesizer, it generally sends the
attached child patches as well (though
some devices do not support this
capability).

•

•

•

If Galaxy finds a Bank of the proper
type, it then searches that Bank to see
if it already contains an identical
patch.
If the Bank contains an identical
patch, Galaxy alters the parent patch
to refer to the location of the duplicate. If, for example, you use the
same bass sound in several parent
patches, you won’t get a separate
copy of it for every parent patch; all
the parent patches will refer to one
copy of the child.
If the Bank doesn’t contain an identical patch, Galaxy tries to store the
patch in the position referenced by
the parent patch. If the location isn’t
empty, Galaxy pastes the child patch
into the first empty location it finds
and alters the parent to refer to that
location. Galaxy will warn you if there
are no empty locations in which to
paste a child patch.

NOTE: The capabilities of attached patches
vary from device to device. You should
always read Galaxy’s on-line help for each
device in your studio. It provides important
information about patch types and the relationships between parent and child patches.
Pasting Parent Patches into a Bundle
If you paste a parent patch with attached
child patches into a bundled Bank, here’s
what happens to each child patch:
•
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Galaxy searches the Bundle for a
Bank containing the same patch type
as the child patch. If it doesn’t find the
proper Bank type, Galaxy warns you
of the problem.
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Banks, Bundles, and Libraries

1
2
3
4
5
6
7
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CHAPTER 4:

Using Galaxy’s On-Line
Librarian Help

Galaxy offers two types of on-line help:
•
•

device specific help
general Galaxy help

The following sections discuss both types
of on-line help.

DEVICE SPECIFIC HELP
On-line help is available for each Librarian
Module installed into Galaxy. Use it to
learn important device-specific information such as: Bank types, special features,
limitations, and set up procedures.
To use device-specific on-line help:
a Open a Bank, Bundle, or Library
window.

Figure 4.1: Typical Help Window

d Click a topic to choose it (it becomes
highlighted), then click the Help
button.
Detailed help on the selected topic
appears in the window.
Alternately, you could simply doubleclick the topic title to read the detailed
help.

b Click the name of the device for which
you need help.

c Choose [Device Name] Help from
the System 7 menu (located in
the upper right corner of the
Macintosh screen) marked with
a “?”.
A Help Window similar to the one shown
in Figure 4.1 will open. This window presents a scrolling list of topics relating to
the device.

Galaxy Manual

Figure 4.2: Specific Topics in Help Text
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e Use the scroll bar to scroll through
the text.
You may use the Previous and Next
buttons to scroll directly to the previous
or next topic in the text. Use the Print
button to print the entire help text, or
choose File>Print.

f Click the Topics button to return to
the list of help topics.

You can leave the Help Window open
while you use Galaxy. Click the window’s
close box to close it.

GENERAL GALAXY HELP
Galaxy also offers general on-line help. To
open Galaxy’s on-line help file, choose
Galaxy Help from the System 7 menu.
You should not consider Galaxy’s on-line
help to be a substitute for the manual.
Please read your Galaxy manual to learn
about all of Galaxy’s powerful features in
detail.
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CHAPTER 5:

Creating and Getting a New
Bundle

By now you should have:
•
•

•

•

Installed the Galaxy application
(including OMS).
Created a current OMS Studio Setup
document that reflects the connection
of MIDI devices in your studio.
Configured Galaxy and installed the
Librarians and Editors that you plan
to use.
Learned basic Galaxy terminology.
It’s essential to understand the terms
used by Galaxy and this manual.
Therefore, if you haven’t read
Chapter 3: Galaxy Terminology, go
back and do so now!

In this chapter you’ll:
•
•
•
•
•
•

Create a new Bundle.
Get patches from your MIDI device
into the Bundle.
Save the Bundle.
Send the Bundle back to your MIDI
device.
Create a Bundle with multiple devices
(optional).
Create a Bundle Template (optional).

CREATING A NEW BUNDLE
The most efficient way to work in Galaxy
is with Bundles. Bundles, as you’ll recall,
allow all related patches from a device(s)
to be contained in a single document.
Bundles also allow you to establish parent
and child patch relations.
To create a new Bundle:
a If you haven’t already done so, start
Galaxy by double-clicking its icon.

b Choose File>New Bundle.
Unless you’ve created Bundle Templates as discussed in Creating Bundle
Templates (pg. 32), Galaxy opens a
Select Device dialog box, which is discussed in The Select Device Dialog Box
(pg. 26).

Figure 5.1: Typical Select Device Dialog Box

Galaxy Manual
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c Select the desired device.
The list scrolls if all the devices don’t fit
in the dialog box.

d Click the OK button.

TOURING THE BUNDLE
WINDOW
Below is a typical Bundle Window.

Galaxy creates a Bundle Window for the
device of the selected type (see
Figure 5.2).

The Select Device Dialog Box

A

As shown in Figure 5.1, there are two columns in the Select Device dialog box:
•

•

Device Type column: This shows all
devices supported by the librarian
modules you’ve installed into Galaxy.
Device in current Setup column:
This lists any devices in your current
OMS Studio Setup document that are
of the Device Type shown in the left
column. If you see dashes, it’s
because your current Studio Setup
document doesn’t contain any devices
of the type installed into Galaxy.

You may wish to check the Only Show
Devices in OMS Setup check box.
When this option is checked, the Select
Device dialog box shows only the
installed devices that are also in your current Studio Setup document.
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4

Figure 5.2: Typical Bundle Window (this one for a
Korg X5 synthesizer)

Bundle Windows (as shown in Figure 5.2)
contain the following elements:
A

OMS Device Selection pop-up menu
B Galaxy Device Type
C Device ID
D Bank List
The following sections discuss how to use
the Bundle Window.
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OMS Device Selection
How you select MIDI devices in the
Bundle Window depends on your current
OMS Studio Setup document:
•

•

If you have only one MIDI device of
the type displayed in the Device Type
column, it is displayed in the Device/
Bank column and no further action is
necessary.
If you have more than one device of
the type displayed in the Device Type
column, you’ll need to tell Galaxy
which device you want assigned to
this Bundle. To do so, select the
desired device from the OMS Device
Selection pop-up menu.

NOTE: If you are using multiple MIDI
devices of the same Device Type, make sure
they have different Device ID numbers.

•

If your current Studio Setup document doesn’t contain any devices of
the chosen type and all of its devices
are defined, you’ll see an alert box
stating that your current Studio Setup
document doesn’t contain any devices
of this type. You’ll need to define the
appropriate device in OMS Setup, or
make current a Studio Setup document containing that device.

To select a specific MIDI device with
which to use this Bundle:
a Press and hold the mouse on the OMS
Device Selection pop-up menu.
Galaxy displays a pop-up menu of all the
devices in your current Studio Setup
document that are of the type displayed
in the Device Type column. The pop-up
menu has multiple selections if your current Studio Setup document contains
more than one device of the indicated
type.

b Use the pop-up menu to select
(check) the device you want to use in
this Bundle.

•

If your current Studio Setup document doesn’t contain any devices of
the type shown in the Device Type
column, then the pop-up menu lists
all the undefined devices in your current Studio Setup document. An
undefined device is any device in
your current Studio Setup document,
that is not known to OMS (name is
set to “other”).

Galaxy Manual

If you have only one device in the pop-up
menu, it’s always the selected device (as
shown in Figure 5.3).
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To view the Bank list without icons:
a Select the Bundle>View By Name
command.

Figure 5.3: Device Selection Pop-up Menu

This will remove the Bank icons from the
Bundle Window, resulting in smaller
Bundle Windows.

NOTE: If you option-click the OMS Device
Selection pop-up menu, you’ll see a list of
all devices in your current Studio Setup
document rather than just those devices of
the selected type.

Device ID
Normally, you cannot use Galaxy to
change a device ID since this is part of the
device information contained in your current Studio Setup document. If you want
to change a device ID, you must do so in
OMS Setup.

Figure 5.4: Bundle Window viewed by name

You can display the icons again by
choosing Bundle>View By Icon as
shown below.

However, if a device is undefined in OMS
Setup, then you can use the device ID
numerical to match Galaxy’s ID to the
undefined device’s ID.

Viewing the Bank List
The Bundle Window’s Bank list shows a
Bank name and icon for every patch type
supported by the device.
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Figure 5.5: Bundle Window viewed by icon
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Choosing the Banks You Want in
the Bundle
There may be times when you don’t need
to include all possible patch types in a
Bundle. For instance, you might have a
device that supports RAM card data transfers, but you don’t want these included in
the Bundle.
To choose the patch types you want
included in a Bundle:
a Choose Bundle>Banks in Device.
Galaxy opens a dialog box listing all the
possible Bank types for that device.

SETTING UP YOUR MIDI
DEVICE
You’re almost ready to transfer patches
from your synthesizer to Galaxy, but you
must first verify that Galaxy and your synthesizer are “speaking the same
language.” To do this:
a Make sure that your synthesizer is
enabled to send and receive MIDI
system exclusive messages.
If necessary, open Galaxy’s on-line help
to learn about enabling system exclusive
messages for your device.

.

THEORY: System exclusive (sys-ex) messages are unique types of MIDI messages
that allow you to send specific patch and
parameter information between identical
synthesizers, or between a synthesizer and a
computer.
b Make sure that your synthesizer’s
Figure 5.6: Choosing Banks to be Included in
the Bundle

b Un-check those Banks you don’t want
included in the Bundle, then click the
OK button.
If you’re not sure what some of the
Banks are for, you should use Galaxy’s
on-line help (as discussed in
Chapter 4: Using Galaxy’s On-Line
Librarian Help).
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device ID matches the Device ID
number shown in the Bundle Window.
If not, you’ll need to open OMS Setup
and modify the Device ID. Your OMS
manual describes Device ID’s and how
to set them.

THEORY: Device ID’s are used to identify
devices that use the same sys-ex messages.
In the same way that note information is
conveyed on a specific MIDI channel, patch
(system exclusive) information usually contains a device ID specifying the device to
which the patch data is directed. You need
to match the Galaxy device ID with the synthesizer’s device ID in order for them to
transfer patch data back and forth. On
some older devices, there is a “basic” MIDI
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channel that also functions as a device ID.
Some manufacturers may use terms like
“MIDI ID,” “unit ID,” “unit number,”
“device number,” or “system exclusive ID”
instead of the term “device ID.”

GETTING A BUNDLE

Figure 5.7: Loading All Banks Progress Dialog
Box

You’re now ready for Galaxy to get its
Bundle with Banks of patches from your
MIDI device.

If the load procedure is successful, all
chosen Banks from the selected device
get loaded into the Banks in your Galaxy
Bundle.

NOTE: Make sure the number and type of
Banks in your Bundle mirror those in your
MIDI device. To do so, use the Bundle>Banks in Device command as
described in Choosing the Banks You Want
in the Bundle (pg. 29).

NOTE: Some synthesizers require that certain buttons be pressed in order for the
transfer to occur. See the device specific
online help for your synthesizer or your synthesizer’s manual for more information.

a Select the device type in the Bundle

SAVING A BUNDLE

Window.

Click here to highlight the MIDI device
from which you want to “get” the
Bundle.

b Choose Bundle>Get All Banks
from [Device].
You’ll see a progress dialog box (unless
the transfer process is very quick).

Make sure to save your Bundle now!
You’ll be modifying Bundles for the
remainder of this manual. By saving this
Bundle, you’ll be able to restore the
memory of your MIDI device to its original state. To save the Bundle:
a Choose File>Save.
Since this is the first time you’re saving
this Bundle, Galaxy opens a Save As
dialog box.

b Select a destination folder, and type a
name for your Bundle.
You should probably type a name like
“Factory Bundle” to identify this Bundle
as the one that will restore the original
memory in your MIDI device.

30

Opcode Systems, Inc.

CHAPTER 5: Creating and Getting a New Bundle

c Click the Save button.
Galaxy saves your Bundle to the folder
or volume you chose.

To create Bundles that contain multiple
devices:
a Create a new Bundle containing the
first MIDI device.

SENDING A BUNDLE TO YOUR
MIDI DEVICE
In this section, you’ll learn how to send a
Bundle back to your MIDI device.
In this particular case, you won’t destroy
any existing patch data in your MIDI
device because you haven't altered any
Banks or patches; the bundled Banks
you’re sending to your synthesizer are the
same as those already in it.

Use the techniques discussed in Creating a New Bundle (pg. 25).

b Choose Bundle>Add Device.
Galaxy re-opens the Select Device
dialog box. Select the device you want to
include in the Bundle. If you want to add
multiple devices, shift-click the additional
devices, then click the OK button.

a Select the Device Type in the Bundle
Window.

b Choose Bundle>Send All Banks to
[Device].
Galaxy sends all Banks in the selected
Bundle back to your device.

c Click the Bundle Window’s close box
to close the window.

CREATING BUNDLES WITH
MULTIPLE DEVICES
You can create Bundles that contain more
than one device. With multi-device Bundles, you can transfer patches between
entire racks of MIDI devices with a single
action.
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Figure 5.8: Multiple Devices in a Bundle

NOTE: If you are using multiple MIDI
devices of the same Device Type, make sure
they have different Device ID numbers.
To load the Bundle with Banks from all
devices:
a Choose Bundle>Get All Banks in
Bundle.
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To get Banks from a particular device:
a Select the device name in the Bundle
Window.

b Choose Bundle>Get All Banks
from [Device].

To send all the Banks in the Bundle to all
the devices:
a Choose Bundle>Send All Banks in
Bundle.

To send Banks to a particular device:
a Select the device name in the Bundle
Window.

b Choose Bundle>Send All Banks to
[Device].

CREATING BUNDLE
TEMPLATES
It would get tedious if you had to add
devices one-by-one every time you wanted
to create a new multi-device Bundle. Fortunately, Galaxy lets you create and save
Bundle Templates. Bundle Templates
save the structure of the active Bundle as a
template for new Bundles.
To create a Bundle Template:
a Click the Bundle Window to make it
the active window.

b Choose Bundle>Save As
Template.
Galaxy opens a dialog box similar to the
one shown in Figure 5.9.

To rearrange the display order of devices
in a Bundle:
a Option-click any Bank in the Bank list
of the device you wish to move.
Do not option-click the OMS Device
Selection pop-up menu or you’ll open a
list of all devices in your current Studio
Setup document.

b Drag the Bank to a new location in the
list and release the mouse button.

Figure 5.9: Bundle Template Dialog Box

c Type a name for the template and
click Save.
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The scrolling list in this dialog box shows
the names of all previously saved Bundle
Templates. If you’re updating an existing
template, click its name in the list, then
click Save. Once you've saved your
Bundle Template, it will appear in a list of
Bundle types when you choose File>New
Bundle.

Deleting Bundle Templates

Using Bundle Templates

c From the dialog box, select the

To delete a Bundle Template:
a Click a Bundle Window to make it
active.

b Choose Bundle>Delete Template.
Galaxy opens a dialog box listing all your
current Bundle Templates.
template you wish to delete.

When you choose File>New Bundle,
you’ll see a Select Template dialog box
showing the names of all your Bundle
Templates, plus an “Empty Bundle”
option.

d Click the Delete button.
e Repeat the previous steps if you want
to delete any more templates.

f Click the Done button.

Figure 5.10: Typical Select Template Dialog Box

Select a Bundle Template to open a new
Bundle with the same characteristics as
the template. Select “Empty Bundle” to
create a new Bundle as discussed in Creating a New Bundle (pg. 25).

Galaxy Manual
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CHAPTER 6:

Using Bundles

In this chapter, you’ll:
•
•
•
•

open Banks in a Bundle
learn about the Bank Window
select patches
name, and send patches to your MIDI
device

OPENING BANKS IN A BUNDLE
Figure 6.1: Opening Bundled Bank

Each bundled Bank contains a single type
of patch. The patch type and the number
of patches contained in the Bank vary
according to the MIDI device. In Galaxy,
Banks are displayed as windows.

Notice that a Bank Window opens and
becomes active.
B

A

C

D

F

To open a bundled Bank Window:
a Double-click the Bank’s name or icon

E

in the Bundle Window or single click
on the Bank’s name or icon and press
the Return or Enter key.
G

Figure 6.2: Bank Window
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TOURING THE BANK WINDOW
Figure 6.2 shows a typical bundled Bank
Window and its elements. A Bank Window’s appearance varies considerably
depending on both the type of MIDI
device and the type of Bank. In most
cases, the Bank Window’s appearance
corresponds to the arrangement of
patches in your device, including the way
the patches are numbered.
Most Bank Windows contain the following elements:
A

B

C

D

E
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Title Bar: displays both the name of
the Bundle to which the Bank
belongs and the patch type of the current Bank.
Device Name: displays the name of
your MIDI device (as defined in your
current OMS Studio Setup
document).
Device ID: displays the Device ID
number (as set in your current OMS
Studio Setup document).
Sub-Instrument Control: This control is not available for all devices.
Use it if your MIDI device supports
sub-instruments. The Sub-Instrument Control is discussed in SubInstruments (pg. 37).
Bank Type: displays the Bank type
shown in the active window.

F

Edit Button: This button is available
only if you installed a corresponding
Editor and are using Galaxy Plus
Editors. Patch Editing is discussed in
Chapter 20: Using Editor Modules.
G Patch List: This area lists all the
patches contained in the Bank. For
more information, see The Patch List
(pg. 36).

The Patch List
Generally, the number of patches in a
Bank Window corresponds to the number
of patches in your MIDI device’s related
Bank. If your MIDI device supports patch
names, these too are displayed in the
Bank Window.
You should know a few important points
about the patches shown in a Bank
Window:
•

•

Many devices don't give names to
some (or all) of their patch types. For
such devices, Galaxy may automatically create a “phony” name such as
“(unnamed),” or it may leave the
name blank.
Only RAM patches are displayed.
Galaxy generally can’t access factory
ROM presets when you’re working
with a Bundle (although the
Proteus/1 is an exception). You can
get ROM patches from some devices,
although not every device allows this.
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•

Some types of MIDI devices may
allow Galaxy to access a cartridge or
RAM card but, in general, you have to
load the cartridge or RAM card into
your device’s internal memory (erasing RAM contents) in order to load
them.

As always, if you have questions about a
specific device, look for the answers in
the device specific on-line help.

Sub-Instruments
Some Bank Windows have a sub-instrument control (as shown in Figure 6.2 on
page 35). If your Bank has a sub-instrument control, read this section.
A Bank Window contains a sub-instrument control if your device:
•
•

is multitimbral
has an edit buffer for each subinstrument

Use the sub-instrument control to:
•
•

tell Galaxy which edit buffer receives
patch information, and/or...
tell Galaxy which channel to use to
audition patches.

Read Galaxy’s on-line help to find out
about your specific devices and their subinstruments.
IMPORTANT: If you’re using a module
created with PatchTalk, patches will usually be sent to sub-instrument #1 by default
and the Bank Window will not contain a
sub-instrument control.
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SELECTING PATCHES
To select a patch (or group of patches) in
a Bank Window:
a Select the patch name.
b To select additional patches, shiftclick their names.
Alternately, you could select multiple
patches by selecting the first un-selected
patch you’d like and then dragging the
cursor over additional patches while
holding the mouse button down. You
must start dragging on an un-selected
patch, otherwise Galaxy assumes you
want to edit the selected patch’s name.

c To de-select a patch, shift-click its
name.

d To select all of the patches in a
window, choose Edit>Select All.
This is useful if you want to copy all of
the patches from a Bank into a Library.

You can also select additional patches
using the Macintosh’s Arrow, Shift, Tab,
and Return keys:
e To select the patch immediately
above the selected patch type the UP
ARROW key.
Alternately, you could type the SHIFTRETURN keys.

f To select the patch immediately below
the selected patch, type the DOWN
ARROW key.
Alternately, you could type the RETURN
key.
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g To select the patch to the left of the
selected patch, type the LEFT
ARROW key.

SENDING INDIVIDUAL
PATCHES TO YOUR DEVICE

Alternately, you could type the SHIFTTAB keys.

You can send single patches to your MIDI
device either manually or automatically.

h To select the patch to the right of the
selected patch, type the RIGHT
ARROW key.
Alternately, you could type the TAB key.

To send a patch to your device manually:
a Select a patch in the Bank Window.
b Choose Load/Send>Send Patch
to (Device).

NAMING PATCHES
You can use Galaxy to rename patches:
a Choose Edit>Enter Names.
When you check this option, Galaxy
enables patch naming. When this item is
un-checked, you cannot edit patch
names.

b Click a patch name.
The cursor becomes an I-beam, indicating you can type a new name.

c Type a new name for the patch.
You can’t use the extended Macintosh
character set since most devices that
store names can’t store these characters. Name length is determined by the
device.

d Press the Enter key.
Galaxy enters the new patch name and
the cursor becomes an arrow.

If you rename any patches, choose
File>Save to save the new patch names in
the Bundle.
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This command displays the name of
your device in place of the word
(Device). When you choose this command, Galaxy sends the selected patch
to your device’s edit buffer.

To send a patch to your device
automatically:
a Select Load/Send>Send on Select
to check it.

b Select a patch in the Bank Window.
Galaxy sends the selected patch to your
device’s edit buffer automatically.

IMPORTANT: If your device doesn't have
an edit buffer, Galaxy dumps the patch into
a predetermined location, usually the highest numbered patch. If that location already
contains a patch, and if Send on Select is
enabled, selecting a patch in a Bank
Window overwrites the patch in that predetermined location. In devices without edit
buffers, the patch location used for Send
on Select usually appears next to the
words “Send on Select.” See Galaxy’s online help for your particular device.
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Stand-Alone Banks

In this chapter, you’ll create and become
acquainted with the stand-alone Bank
Window.

CREATING A STAND-ALONE
BANK
To open a stand-alone Bank:

STAND-ALONE BANK BASICS
Generally, you’ll use bundled Banks with
your MIDI device because of their many
benefits. However, Galaxy gives you the
ability to create stand-alone Banks that
are not part of a Bundle. Stand-alone
Banks differ from bundled Banks in the
following ways:
•

•

•

Child patches are not attached when
you fill a stand-alone Bank (unless
you copy patches from a bundled
Bank).
When you edit a patch in a standalone Bank, you won’t see child patch
names in any edit windows.
You select the OMS device in the
Bank Window rather than the Bundle
Window.

If you don’t expect to use stand-alone
Banks, you can skip ahead to
Chapter 8: Libraries.
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a Choose File>New Bank.
A dialog box opens with a scrolling list of
all the Bank types for all the devices supported by the Librarian Modules you
installed into Galaxy.

Figure 7.1: New Bank Dialog Box

b Select a Bank type, then click the OK
button.
Alternately, you could simply doubleclick the Bank type. Galaxy opens a
new, stand-alone Bank of the type you
requested.
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TOURING THE STAND-ALONE
BANK WINDOW
The stand-alone Bank Window is nearly
identical to the bundled Bank Window
with following differences:
•

•

•
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The title bar of a stand-alone Bank
displays only the name of the Bank.
This is an easy way to tell if a Bank is
bundled or stand-alone.
You must select the device with
which you want to communicate
directly from the stand-alone Bank
Window. Device selection works
exactly the same as in a Bundle Window. See OMS Device Selection
(pg. 27) for more information.
Device ID viewing and/or selection
works the same as in a Bundle Window. See Setting Up Your MIDI
Device (pg. 29) for more information.
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Libraries

In this chapter, you’ll:
•
•
•
•
•

create a new Library
learn your way around the Library
Window
fill a Library with patches, eliminating
duplicates
save the Library
send patches from a Library to your
MIDI device

device doesn't have an edit buffer,
patches usually go to the highest numbered patch location. See Sending
Individual Patches to your Device (pg. 38)
for more information.

CREATING A LIBRARY
To create a Library:
a Choose File>New Library.

LIBRARY BASICS
As discussed in Understanding Galaxy
Patch Hierarchy (pg. 18), Galaxy supports
another type of patch storage file called a
Library. Unlike Banks, Libraries arrange
patches alphabetically. The number of
patches contained in a Library is limited
only by Macintosh memory.
Libraries are very useful storage files. You
can, for example, combine all the Banks
you have into a single Library, and then
use the Library to build new Banks.
Libraries have limited Load/Send capabilities; they transfer only one patch at a
time between Galaxy and your MIDI
device. Galaxy sends patches from a
Library to the device’s edit buffer. If the
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A dialog box opens showing all the possible Library types. The list is based on
the modules you installed into Galaxy.

Figure 8.1: New Library Dialog Box
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b Select a Library type, and click the
OK button.
Alternately, you could simply doubleclick the Library type. A Library Window
opens similar to the one shown in
Figure 8.2.
B

A

C

D
G

E

F
H

Figure 8.2: Anatomy of the Library Window

TOURING THE LIBRARY
WINDOW

E

Patch Type: This area displays the
type of patch contained in the Library.
F Number of Patches in Library: This
area displays the total number of
patches contained in the Library.
G Edit Button: This button is available
only if you installed an editor module
for the device and are using Galaxy
Plus Editors. Click the button to open
an edit window for the patch type
shown in the window. Patch editing
basics are discussed in
Chapter 20: Using Editor Modules.
H Patch List Area: This area contains an
alphabetical list of all the patches in
the Library.
As always, if you have questions about a
specific device, look for the answers in
Galaxy’s on-line help.

Figure 8.2 shows a typical Library
Window and its elements:

Device Selection

A

As in Bundle Windows and in stand-alone
Banks, you can choose the device with
which you want to communicate from the
OMS Device Selection pop-up menu.

Device Icon: This is the icon used to
represent a device in the OMS Studio
Setup document.
B OMS Device Selection pop-up menu:
Use this pop-up menu to select the
OMS device to which this Library will
communicate.
C Device ID: This numerical displays
the Device ID of the selected MIDI
device (as set in your current OMS
Studio Setup document).
D Sub-Instrument Control: This control
is not available for all devices. Use it
to set a sub-instrument control as discussed in Sub-Instruments (pg. 37).
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Figure 8.3: Selecting an OMS Device

Device selection works exactly the same
as in a Bundle Window. See OMS Device
Selection (pg. 27) for more information.
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FILLING A LIBRARY
To fill a Library, you’ll have to copy and
paste patches from Banks (either bundled
or stand-alone). Galaxy gives you numerous ways to perform this cut and paste
operation.

1. Hold down the option key and click the desired
patch in the Bank Window

NOTE: Patches in an open Library are
stored entirely in your computer’s memory.
Therefore, the size of a Library is limited
both by the amount of available computer
memory, and the amount of available disk
space.
2. Drag the patch over to a Library Window

Copying Single Patches
To copy a single patch into a Library:
a Option-drag the desired patch from
the Bank Window to anywhere in the
Library Window (as shown in
Figure 8.4).
Alternately, select the patch and use
standard Macintosh Copy and Paste
methods.
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3. Release the mouse button to paste the patch
into the Library

Figure 8.4: Drag Copying a Patch
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Copying a Contiguous Patch
Group

Copying a Discontiguous Patch
Group

To copy a contiguous group of patches
into a Library:

To copy a discontiguous group of patches
into a Library:

a Select a contiguous group of patches

a Click the first desired patch.
b Shift-click each additional patch you

by dragging over them.

wish to copy to a Library.

Figure 8.5: Dragging Patches To Create A
Contiguous Group

b Option-drag any one of the selected
patches from the Bank Window to
anywhere in the Library Window.
Alternately, you could use standard Macintosh Copy and Paste methods.

Figure 8.6: Shift-Clicking Patches To Create A
Discontiguous Group

c Option-drag any one of the selected
patches from the Bank Window to
anywhere in the Library Window.
Alternately, you could use standard Macintosh Copy and Paste methods.

Copying an Entire Patch Bank
To copy an entire Bank of patches into a
Library:
a Click the Bank Window to make it the
active window.

b Choose Edit>Select All.
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c Option-drag any one of the selected
patches from the Bank Window to
anywhere in the Library Window.
Alternately, you could use standard Macintosh Copy and Paste methods.

The Duplicate Name Alert Box gives you
a few options for handling patches with
duplicate names:
•
•

•

•
Figure 8.7: Typical Library with Patches

PATCH NAMES IN A LIBRARY
Every patch in a Library must have a
unique name. If you paste a patch into the
Library, and there is already a patch with
the same name, a dialog box appears
prompting you to either rename the patch
or eliminate one of the two patches.

•

•

Replace—Replaces the existing
Library patch with the pasted patch.
Always Replace—If you click this
button, Galaxy always replaces the
existing Library patch with the pasted
patch. Galaxy does not produce the
Duplicate Name alert box for the
remainder of the paste operation.
Keep Existing—Keeps the existing
Library patch and discards the patch
you’re pasting.
Always Keep—If you click this button, Galaxy always keeps the existing
Library patch and discards the patch
you’re pasting. Galaxy does not produce the Duplicate Name alert box
for the remainder of the paste
operation.
Rename New—Enter a new name
and click this button to keep both the
existing and the pasted patch. If the
new name is not already in the
Library, the patch will be added with
its new name. The copy of the patch
on the Clipboard will not be renamed.
Always Auto-Rename—Clicking
this button causes Galaxy to rename
patches automatically. It does this by
changing the last characters of the
name until the name doesn’t match

Figure 8.8: Duplicate Name Alert
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any others in the Library. Select Setups>Preferences to tell Galaxy how
you want it to automatically rename
patches. Your choices are to:
• Append numbers to the patch
name, starting at 0.
• Append capital letters to the patch
name, starting at “A”.
• Append small letters to the patch
name, starting at “a”.
If you rename a patch in a Library, it
is immediately re-alphabetized. You
may have to scroll in order to locate
the renamed patch.

alert tells you the name of the patch
you're pasting and the name of any and
all duplicate patches in the Library.

Figure 8.9: Duplicate Patch Parameter Alert

d Click the Listen button if you need to
hear what a patch sounds like.

AVOIDING DUPLICATE
PATCHES
To avoid pasting patches with duplicate
patch parameters:
a Select Setup>Preferences.
b Check the No Duplicate Patches
in Libraries option.

c Paste patches into the Library.
Galaxy compares each pasted patch’s
parameters to the parameters of all
patches in the Library. If two patches
have different names but duplicate
parameters, Galaxy produces a Duplicate Patch Parameter Alert box (similar
to the one shown in Figure 8.9). This
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This sends the patch to your MIDI device
so you can audition it (using techniques
discussed in Chapter 10: Auditioning
Patches).

e Select the name you wish to use, then
click the OK button.

When both the name and the patch
parameters of a pasted patch match an
existing patch in the destination Library,
the second patch is never pasted, and
you’ll never see any dialog boxes, regardless of any preference settings.
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If a pasted patch has the same name as
one patch and the same parameters as
another, Galaxy decides what to do based
on the status of the Ignore Names in
Duplicate check box in the Preferences
dialog box:
•
•

If the box is checked, the patch is
ignored and not pasted.
If the box is un-checked, Galaxy first
produces an alert box asking you to
rename the pasted patch (to resolve
the name conflict), followed by
another alert box indicating that
other patches have duplicate
parameters.

SAVING A LIBRARY
Libraries are saved just like Banks:

SENDING A LIBRARY PATCH TO
A DEVICE
You can send only one patch at a time
from a Galaxy Library to a MIDI device.
To send a patch:
a Click a Library Window to make it
active.

b Select the Load/Send>Send on
Select option (checking it).

c Select a patch in the Library Window.
Galaxy sends the selected patch to your
device’s edit buffer automatically.

NOTE: You cannot use the Load/Send
menu commands to transfer patches
between Libraries and devices (the commands are disabled).

a Click the window of the Library you
want to save (making it the active
window).

b Choose File>Save.
If you’re saving a new, previously
unsaved Library, you’ll see a standard
Save As dialog so you can name the
Library and save it in the desired folder.

Galaxy Manual
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CHAPTER 9:

Bits and Pieces

In this chapter, you’ll:
•
•
•
•
•

Review copy and paste techniques.
Learn to recognize parent patches.
View child patch information.
Send parent/child patches to your
MIDI device.
Print the contents of a Bank or
Library.

CUT, COPY AND PASTE
REVIEW
You’ve already learned some techniques
for transferring patches between Banks
and Libraries. In general, you can apply
these same techniques to any patch
transfer.
There are two ways to move a patch from
one Bank (or Library) to another:
•

•

You can use the standard Macintosh
Cut, Copy, and Paste commands,
or...
you can use the Option-drag method.
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The Option-Drag Method
As you first learned in Filling a Library
(pg. 43), you can option-drag a patch to
copy it to a new location. Similarly, if you
select a group of patches, you can copy
and paste the entire group by option-dragging the entire group to a new window.
You can use the option-drag method to
copy and paste patches between Banks or
Libraries. If you need to review the various option-drag techniques, see Filling a
Library (pg. 43).
Option-Dragging to a Bank
When you option-drag a group of patches
into a Bank Window, you don’t need to
worry about positioning the mouse;
Galaxy automatically pastes the patches
into the first empty locations within the
Bank. If there aren’t enough locations,
some patches won’t be pasted. However,
when option-dragging single patches, the
patch will be pasted into the location
where you release the mouse button. If a
patch is already in that location, it will be
over-written.
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Option-Dragging to a Library
When you option-drag a patch (or group
of patches) into a Library Window, you
don’t need to worry about positioning the
mouse; Galaxy pastes the patches into the
Library alphabetically. If the Library
already contains patches, they will shift
around to accommodate the new patches.

The Cut/Copy/Paste Method
If you prefer, you can move patches using
the standard Cut, Copy, and Paste commands. To move patches between Banks:
a Select the desired patches.
b Choose Edit>Cut or Edit>Copy.
c Select the destination patch
locations.

d Choose Edit>Paste.
Pasting to a Bank or Library
Unlike the option-drag method, when you
use the Paste command to paste patches
into a Bank, you must first select paste
destinations in the Bank Window. You do
not have to select a paste destination in a
Library; patches are pasted alphabetically.

PASTING PARENT & CHILD
PATCHES
If you copy a parent patch from a bundled
Bank to either a stand-alone Bank or a
Library, Galaxy copies its child patches
automatically. Parent and child patches
are described in Attached Patches
(pg. 19).
Not all devices use parent and child patch
types. See Galaxy’s on-line help for your
particular MIDI device.

Recognizing Parent Patches
In a stand-alone Bank or Library, a plus
(+) sign to the right of a patch name indicates that the patch is a parent patch with
attached child patches.
For example, the patches in the Library
shown in Figure 9.1 were copied from a
bundled Bank. Notice that Galaxy
attached child patches and indicated their
presence by a plus (+) sign.

Figure 9.1: Patches with Attached Child Patches are
marked with a + Sign
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Viewing Child Patch Information
You can view information about a child
patch (such as the patch type and its location) by choosing Edit>Child Patch
Info. A parent patch must be selected for
this option to be available in the Edit
menu.

For example, when you send a linked
preset to a Proteus, you would want
Galaxy to send all attached presets automatically. Galaxy generally sends
attached patches whenever the MIDI
device allows it. Unfortunately, some
types of MIDI devices do not have this
capability. See the on-line help for your
device.

Pasting Parent Patches into a
Bundle
If you copy a parent patch with attached
child patches from a stand-alone Bank or
Library and paste it into a bundled Bank,
the following behavior is executed for
each child patch:
•

Figure 9.2: Viewing Child information

Sending Parent Patches

•

•

When you send your MIDI device a
parent patch from a stand-alone Bank or
Library, Galaxy also sends all its attached
child patches.

•
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Galaxy searches the Bundle for a
Bank containing the same patch type
as the child patch. If it doesn’t find the
proper Bank type, Galaxy warns you
of the problem.
If Galaxy finds a Bank of the proper
type, it then searches that Bank to see
if it already contains the child patch.
If the Bank contains the child patch,
Galaxy alters the parent patch to refer
to the location of the duplicate. If, for
example, you use the same bass
sound in several parent patches, you
won’t get a separate copy of it for
every parent patch; all the parent
patches will refer to one copy of the
child.
If the Bank doesn’t contain the child
patch then it is pasted along with the
parent patch.
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PRINT THE CONTENTS OF A
BANK OR LIBRARY
You can print the names of all the patches
in the active window by choosing the
File>Print command. Names are printed
using the same type font (Geneva 9) that
is displayed on the screen. Banks are
printed in the same format as shown on
the screen. Libraries are printed in several columns. Choosing the Print
command is like choosing Page Setup
followed by Print in most other Macintosh programs. You may choose any
orientation and print method for your
printout. See Print (pg. 90) for more information on how to print from Galaxy.
NOTE: If you are using the serial port that
your printer is connected to for MIDI communications, you must disable it in the
OMS Setup dialog box (accessed in the
Setups menu) for printing to work.
If you don’t like the way Galaxy prints
patches, simply copy the names to the
Macintosh Clipboard, then paste them
into a word processing, spreadsheet, or
database program. To do so:
a Choose Edit>Copy Names.
Galaxy automatically copies all the patch
names in the active window to the Macintosh Clipboard as two columns of text
separated by a tab.
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There are four ways to audition patches
with Galaxy:
•
•
•
•

Play Galaxy’s MouseKeys™
Play your MIDI keyboard
“Play” your Macintosh keyboard
Play a sequence that you record using
either a MIDI keyboard or Galaxy’s
MouseKeys

ANATOMY OF THE MOUSEKEYS
WINDOW
Channel/Device
Selection Controls

MouseKeys
Controls

MouseKeys
Keyboard

PLAYING THE MOUSEKEYS™

Figure 10.1: Typical MouseKeys Window

Galaxy’s MouseKeys consists of a tiny,
graphical, on-screen keyboard—you use
the mouse to “play” the keyboard. In addition to the graphical keyboard, the
MouseKeys Window contains numerous
controls to help you audition patches.

As seen in Figure 10.1, the MouseKeys
Window contains numerous controls and
features. Each of these is discussed in the
following sections.

To open the MouseKeys Window:

MouseKeys Keyboard

a Select Play>MouseKeys.

Use the MouseKeys keyboard to audition
patches right from your Macintosh
screen.

Galaxy opens a MouseKeys Window
similar to the one shown in Figure 10.1.

Galaxy Manual
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Octave Shift
Buttons

Keyboard

Figure 10.2: MouseKeys Keyboard

To use the MouseKeys keyboard:

The MouseKeys keyboard sends MIDI
data to the device and MIDI channel(s)
specified by the Channel/Device Selection Controls as discussed in Channel/
Device Selection Controls (pg. 57).
Octave Shift Buttons
Each “C” key shown on the MouseKeys
keyboard displays the MIDI octave
number.

a Select the Load/Send>Send on
Select option to check it.
Checking the Send on Select option
causes Galaxy to automatically send
patches to your synthesizer’s edit buffer
each time you click a patch name in
Galaxy. If your synthesizer doesn’t have
an edit buffer, the patch will be sent to
the highest numbered patch location.

b In either a Bank Window or Library
Window, select a patch to audition by
clicking it.
If you checked the Send on Select
option (as recommended in step #1),
Galaxy automatically sends the patch to
your synthesizer’s edit buffer.

MIDI octave numbers

You can transpose the keyboard up or
down in single octave increments by clicking the octave shift arrows at each end of
the keyboard.

c Click the MouseKeys keyboard to play
notes, and release the mouse to stop
the note from sounding.
You can click individual notes, or you
can drag the mouse across the keyboard
(like dragging your finger around on a
real keyboard).
MouseKeys are velocity sensitive; the
closer you click to the bottom of a key,
the greater the “velocity” (as though you
struck a real piano key with more force).
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Channel/Device Selection
Controls
Use the Channel/Device Selection Controls to specify which device to
communicate with, and to tell Galaxy
which MIDI channel(s) to use to communicate with that device.
E

A
B

D

C

Figure 10.3: Channel/Device Selection Controls

As shown in Figure 10.3, there are four
different Channel/Device Selection
Controls:
A

Device Selection pop-up menu
MIDI channel selectors
C Multi option
D Auto option
E MIDI Indicator region
B

The following sections discuss each control in detail.

Device Selection Pop-Up Menu
Choose the device that you want to hear
from the Device Selection pop-up menu.
This menu displays the MIDI devices
defined in your current Studio Setup
document.
NOTE: Choosing a device from this menu
automatically disables the Auto option.
The Auto option is discussed in Auto Check
Box (pg. 58).
MIDI Channel Selectors
If you’re working with layered sounds in a
multitimbral synth (such as a Proteus,
Kurzweil K2000, D-110, etc.) or if you’re
using Galaxy to control a signal processor
(like the PCM-70 or LXP-1), you may want
to send MIDI data on several channels, or
on a different channel than the one used
to send patch information.
To select the playback channel(s):
a Click the little channel numbers in the
MouseKeys Window.
You can enable additional channels by
clicking on them.

b Click keys on the graphical
MouseKeys keyboard.
Galaxy sends MIDI data on each of the
selected channels to the selected
device.

NOTE: When you use the MIDI Channel
Selectors to select MIDI channels, Galaxy
automatically disables the Auto option.
The Auto option is discussed in Auto Check
Box (pg. 58).
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Multi Check Box
The Multi box, when enabled (shaded),
allows Galaxy to:
•

•

Echo the input from your MIDI keyboard using the channel(s) on which
the keyboard transmits.
Play sequences using the channel(s)
on which the sequence was recorded.
Sequences are discussed in Playing
Sequences (pg. 62).

This is useful if you want a master MIDI
keyboard to transmit on multiple channels to multiple synthesizers (or a
multitimbral synth). The Multi setting
doesn’t affect Macintosh or MouseKeys
playing, but for keyboard echo and
sequences it takes priority over automatic
or manual channel selection.
NOTE: If the Multi check box is shaded,
notes recorded from MouseKeys will be
played back on the lowest numbered channel selected in MouseKeys.
Auto Check Box
If the Auto box is shaded, Galaxy gets the
device and MIDI channel information
from the active Bank or Library Window.
Galaxy then sends notes from the
MouseKeys to the device displayed in the
active Bank or Library Window (usually
using the window’s Device ID as a MIDI
channel).
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If the active Bank or Library has a
sub-instrument control, the MouseKeys
MIDI channel usually defaults to the
channel on which the current sub-instrument is receiving. Sub-instruments are
defined in Sub-Instruments (pg. 37).
Here are two device-specific examples
that illustrate how the Auto check box
interacts with sub-instruments:
•

•

Proteus—If the active Bank Window’s sub-instrument control is set to
Ch 14 (in the Proteus, the 14th subinstrument always receives on
channel 14), then channel 14 will be
the default MouseKeys channel.
Roland D-110—If you send a multitimbral setup patch to the synth, and
if the active Bank Window’s subinstrument control is set to Part 5
(Roland’s term for the fifth sub-instrument), and if the D-110 is configured
such that Part 5 receives on MIDI
channel 12, then channel 12 will be
the default MouseKeys channel.

Use Galaxy’s on-line help to see if your
device uses sub-instruments and, if so,
how to use them.
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MIDI Indicator
A tiny arrow to the left of the Thru Instrument icon indicates when MIDI data is
being transmitted between Galaxy and
your Thru Instrument.
If the arrow points toward the Thru Instrument, it indicates MIDI data is being sent
to the Thru Instrument.

MIDI Indicator illustrates that Galaxy is sending MIDI data to the Thru Instrument

As shown in Figure 10.4, there are four
different MouseKeys Controls accessed
directly from the MouseKeys Window:
A

Velocity Range control
LazyKeys button
C Repeat button
D Repeat Rate numerical
B

These and other MouseKeys Controls are
discussed in the following sections.
NOTE: The “Mac Vel” numerical is discussed in Macintosh Keyboard Velocity
Control (pg. 61).
Velocity Range Control

If the arrow points away from the Thru
Instrument, it indicates MIDI data is arriving from the Thru Instrument.

MIDI Indicator illustrates that Galaxy is sending MIDI data to the Thru Instrument

MouseKeys Controls
Use the MouseKeys Controls to tell
Galaxy how you want the MouseKeys
keyboard to respond to your mouse
clicks.
A

B

C

D

MouseKeys are “touch-sensitive”.
Although the Macintosh has no way of
knowing how firmly you click the mouse,
you can generate different amounts of key
velocity by clicking in different parts of
the key. To experiment with this, first
make sure you’re using a device that recognizes key velocity, and a sound
programmed with a large amount of sensitivity to key velocity. The higher up you
click on a note, the more softly it plays
(less leverage on the key). The lower you
click on the note, the louder it plays
(more leverage on the key).
Clicking
toward the
top of the key
results in low
key velocity

Clicking
toward the
bottom of the
key results in
high key
velocity

Figure 10.4: MouseKeys Controls
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The shaded bar in the middle of the area
above the keyboard controls the Key
Velocity Range of the MouseKeys. To
change the MouseKeys velocity range,
click at the high or low end of the range,
then drag the gray area to the other end
of the range. If you want to confine the
range to a specific value, just click anywhere on the bar and don’t drag the
mouse.

Repeat Button and Repeat Rate
When you click the Repeat button (highlighting it), the most recently triggered
note plays repeatedly at a rate determined
by the Repeat Rate numerical.
You can set a repeat rate ranging from
0 to 120 (roughly 0.5 Hz to 60 Hz).
Repeat option enabled at a rate of
90 (approximately 45 Hz).

Wide Key Velocity Range

Narrow Key Velocity Range

Figure 10.5: Setting Key Velocity Range

Simply click the Repeat button again to
turn it off.

LazyKeys Button
Sustain Pedal
When you click the LazyKeys button
(highlighting it), you no longer need to
click the mouse to play the MouseKeys
keyboard. New notes are triggered every
time you move the mouse over a
MouseKeys key. Notes sustain until you
either:
•
•

Use the Macintosh’s option key to sustain
a note. This simulates the same effect as
holding down a sustain pedal on a piano.
To create “chords”, simply option-click
each note in the chord.

click the MouseKeys keyboard, or
move the cursor off the MouseKeys
keyboard

Simply click the LazyKeys button again
to turn it off.
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Macintosh Keyboard Velocity
Control

If you want to move or close the
MouseKeys Window, you’ll need to make
it the topmost window. To do so, click
directly on its left-hand title bar. Alternately, to move the MouseKeys Window,
option-click anywhere on the window
(except on the keys).

Figure 10.6: Setting Key Velocity

Use this numerical to set the velocity of
notes you play on the Macintosh keyboard. In addition to the standard
methods of entering numbers in numericals, you can type the numbers
1 through 9. Each of the number keys
sets a predetermined value. For example,
1 enters a velocity value of 1; 5 enters a
velocity value of 64; and 9 enters a velocity of 127.

Click here to make MouseKeys
the topmost window.

PLAYING YOUR MIDI
CONTROLLER

NOTE: To play notes from the Macintosh
keyboard, you must check the Edit>Testing Sounds option. See “Playing” the
Macintosh Keyboard (pg. 62).

You can audition selected patches using
your MIDI Controller. If you’re auditioning patches on a rack-mount sound
module, you should attach a MIDI controller to the Macintosh interface’s MIDI
IN port—this lets you play notes on a keyboard while you listen to them on the
sound module.

Moving and Closing the
MouseKeys Window

To use your MIDI controller with Galaxy:

The MouseKeys Window is always active.

a Choose Setups>Enable Input
Devices.

Contrary to what typically happens when
you click a window, the MouseKeys
Window does not become the topmost
when you click within it. This makes it
easy to audition patches using
MouseKeys without disabling the active
Bank, Library, or Edit Window.

Galaxy opens the Enable Input Devices
dialog box. This dialog box displays the
names of the MIDI devices contained in
your Studio Setup document.

b Check the box next to your MIDI
controller in the Enable Input Devices
dialog box.
Enabled devices are checked; disabled
devices are not.

Galaxy Manual

61

PART 3: Auditioning, Cataloging, and Finding Patches

c Select the Play>Keyboard Thru
option to check it.
Galaxy sends the MIDI information
received from the controller back out to
the device and channel selected in the
MouseKeys Window.

“PLAYING” THE MACINTOSH
KEYBOARD
You can also use the Macintosh keyboard
to send notes to your MIDI device. To do
so:

NOTE: The black piano keys may not be
played from the Macintosh keyboard.

PLAYING SEQUENCES
Another way to audition patches is to
record a small sequence that Galaxy can
play to audition each sound. This is particularly useful if you want to hear a sound in
a particular musical context.
The following sections discuss how to
record sequences and how to use them to
audition patches.

a Select the Edit>Testing Sounds
option to check it.
This option lets you “play” notes on the
Macintosh keyboard without concurrently changing the patch name.

b Type any of the keys shown in
Figure 10.7.

Recording a Sequence
To record a sequence:
a Choose Play>Record Sequence.
b Play a series of notes on your MIDI

The Z key is middle-C.

keyboard or on the MouseKeys.

You can shift the range down three
octaves by holding the shift key (or
engaging the Caps Lock key).

Make sure your MIDI keyboard is
enabled in the Enable Input Devices
dialog box (accessed by choosing Setups>Enable Input Devices).

c Click the mouse when you want to
stop recording.

QWERTYU
ASDFGHJ
ZXCVBNM
Figure 10.7: Playing the Macintosh Keyboard
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Playing a Sequence
There are a couple ways to audition
patches with a playback sequence. You
can either:
•
•

trigger sequences manually, or
trigger sequences automatically
every time you select a patch.
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To play a sequence manually:

Playing a MIDI File

a Choose Play>Play Sequence.

You can also play a prerecorded sequence
that has been stored as a Format 0 (single
track) Standard MIDI File. To do so:

Galaxy plays the sequence.

To play a sequence automatically:
a Select the Load/Send>Send on
Select option to check it.
Checking Send on Select causes
Galaxy to automatically send each
selected patch to your sound module.

b Select the Load/Send>Play on
Select option to check it.

c Select a patch in a Bank or Library.
Galaxy plays the sequence every time
you select a new patch (because the
Play on Select option is checked).

a Choose Play>Open MIDI File.
Galaxy opens a standard Macintosh
Open dialog box.

b Select the MIDI file you wish to open,
then click the Open button.

c Choose Play>Play Sequence.
Sequence playback and looping work
exactly as if you had recorded the
sequence using the Play>Record
Sequence command. For more information, see Chapter 17: Play Menu.

d Select Load/Send>Play on Select
when you’re finished auditioning
patches.
This disables the automatic sequence
playback feature so you can continue
with your work.

Looping a Sequence
You can make a sequence loop
continuously:
a Select the Play>Loop Sequence
option to check it.

Stopping a Sequence
To stop playback of a sequence at any
time:
a Choose Play>Stop Sequence.
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PATCH INFORMATION
As your patch library grows, it gets
increasingly difficult to organize, find, and
retrieve specific types of patches. For this
reason, Galaxy provides different types of
patch information, which you can use to
catalog and search patches.
You can catalog each patch with one or
more types of patch information.
Specifically:
•

•

Patch Names—You can name
patches and later search your Libraries and Banks for specific or partial
patch names.
Keywords—You can attach descriptive keywords to each patch and later
search your Libraries and Banks
based on those keywords. Galaxy
comes with an extensive list of preset
keywords, each of which represents a
precise musical, MIDI, or audio term.
In addition, you can create your own
keywords. In addition, in OMS 2.0
compatible applications such as
Vision, you can view patches by
keywords.

NOTE: See Appendix B Using Galaxy with
the OMS Name Manager for complete
details.
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•

Comments—You can enter text comments (up to 60 pages) containing
any information you might want
about a particular patch, and later
search your Libraries and Banks for
matching text strings.

This chapter tells you how to attach
preset keywords to your own patches, and
how to create custom keywords. It also
tells you how to attach comments to
patches. Chapter 12: Finding Patches tells
you how to search your patches for specific patch information.

ATTACHING KEYWORDS TO
PATCHES
To attach keywords to a particular patch:
a Open the Bank or Library Window
containing the patch to which you
want to attach keywords.

b Select the desired patch by clicking
its name (highlighting it).

c Choose Edit>Patch Info to open the
Patch Information dialog box.
Notice the name and number of the
selected patch appears in the upper right
corner of the dialog box. In Figure 11.1,
the patch number is 71 and the name is
“Dark Violas”.
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Figure 11.1: Open the Patch Information Dialog
Box

You’ll see two list headings at the left of
the Patch Information dialog box:
•

•

Categories—This lists all preset and
custom categories. When you select a
category, all its related keywords are
displayed in the Keywords list.
Keywords—This lists all preset and
custom keywords assigned to a specific category. Appendix A: Keywords
contains a list of all Galaxy’s preset
keywords. You may also create
custom keywords as described in Creating Custom Categories and Keywords
(pg. 68).

Figure 11.2: Selecting a Category and a
Keyword

f Click the Attach >> button.

Alternately, you could either type the
Return key, or double-click the selected
keyword. Any of these methods attaches
the selected keyword to the patch and
causes it to appear in the list of attached
keywords in the right of the dialog box.

d Click a category in the Categories
list to select it (highlighting it).
Notice that Galaxy automatically displays all related keywords in the
Keywords list.

e Click a keyword in the Keywords list
to select it (highlighting it).
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Figure 11.3: The Keyword is Attached to the
Patch
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g Attach as many keywords as you
want from as many categories, then
click the Done button.
Galaxy’s Bank and Library Windows
indicate cataloged patches with the letter
“I”.

Galaxy produces a dialog box asking if
you really want to attach the selected
keyword to all patches in the Bank or
Library.

c Click the OK button.

Stepping Through Patches
Reordering Keywords
You can reorder keywords or categories
in any of the three fields by Option-dragging the desired word.

You can step through patches without
closing the Patch Information Dialog box.
This makes it convenient to attach keywords to many patches in a single
session.

Detaching Keywords

a Click the Next button to move to the
next patch.

To detach keywords from patches:
a In the Keywords list, click a keyword
to select it.

b Click the Detach button.
Galaxy detaches the keyword from the
patch and removes it from the attached
keyword list.

Attaching Keywords to All
Patches in a Bank or Library
You can attach a keyword to all patches in
a Bank or Library:
a Select a keyword.
b Click the >> to All... button.
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If the Load/Send>Send on Select
option is checked, clicking the Next
button also sends the patch to your
device (so you can hear it while you
decide what keywords to attach).

b Click the Previous button to move to
the previous patch.
If the Load/Send>Send on Select
option is checked, clicking the Previous
button also sends the patch to your
device (so you can hear it while you
decide what keywords to attach).

NOTE: Some patch types can’t send a
patch, they can only send entire Banks. In
such cases, after you click Previous or
Next with Send on Select checked, you’ll
see a dialog box containing the message
“Sorry, single patches cannot be sent. Try
send bank.” To keep from seeing this dialog
box, un-check Send on Select for those
types of patches.
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CREATING CUSTOM
CATEGORIES AND KEYWORDS
To create a custom category:
a Click the Add button below the
Category list.

b Type a name for the new category in
the dialog box that opens.

c Click the OK button.
Galaxy adds your custom keyword to the
Keywords list and opens another Add
dialog box. This makes it easy to add
many keywords at once.

d Type in more keywords and continue
hitting the OK button after each entry.

e When you’re finished adding
keywords, click the Add dialog box’s
Cancel button.
You’ll see your new custom keywords
listed in the Patch Information dialog
box.

Figure 11.4: Type a Name in the Add Category
Dialog Box

c Click the OK button.
Galaxy adds your custom category to the
Categories list.

To create custom keywords in either a
custom or existing category:
a Click the Add button below the list of
keywords.

b Type a new keyword in the dialog box
that opens.

NOTE: You can reorder categories and keywords in their respective lists by Optiondragging them to new positions.
You can attach custom keywords to
patches the same as you attach factory
keywords.

Deleting Custom Categories and
Custom Keywords
To delete a custom category:
a Click the category to select it
(highlighting it).

b Click the Delete button below the
Categories list.
Galaxy deletes the custom category.

Figure 11.5: Type a Name in the Add Keyword
Dialog Box
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To delete a custom keyword:
a Click the keyword to select it
(highlighting it).

b Click the Delete button below the
Keywords list.
Galaxy deletes the custom keyword.

IMPORTANT: You cannot delete factory
preset categories or keywords. Also, you
can’t delete categories or keywords if they’re
attached to patches in an open file.
Deleting Custom Keywords Referenced
by Unopened Files
If you delete a custom keyword from a
list, but that keyword is attached to a
patch in an unopened file, then Galaxy
automatically re-adds the deleted keyword to your list when you next open that
file.
If you don’t want Galaxy to automatically
re-add that keyword (or category) to your
list, you must delete all instances of the
removed keyword in any patches in any
unopened files.

Figure 11.6: Attaching Patch Comments

The Comments field scrolls as more text
is typed. To view text that is not displayed:
•

Click in Comments field and use the
Up or Down Arrow keys to move the
cursor to the desired location.

or...
•

Select any visible text and, while holding down the mouse button, drag up
or down. As the mouse position
reaches the top or bottom of the
Comments field, the text scrolls
accordingly.

Closing the Patch Information
Dialog Box

ATTACHING COMMENTS TO
PATCHES

To close the Patch Information dialog
box:

To attach comments to a particular patch:

a Click the Done button, or press the
Enter key.

a Click in the Comments field (in the
lower right of the Patch Information
dialog box).

Galaxy’s Bank and Library Windows
indicate cataloged patches with the letter
“I”.

b Type any comment (up to 60 pages).
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SHARING PATCHES WITH
ATTACHED CUSTOM
KEYWORDS
When you save a file that contains patches
with attached custom keywords, those
keywords are also saved and will appear
in the Patch Information dialog box when
you re-open that file.
NOTE: If you give a patch file to a friend,
and that file contains patches that use
custom keywords, those keywords are added
to your friend’s keyword list automatically
when he or she opens the file.

SAVING PATCH INFORMATION
Custom categories and keywords are
saved in a file called “Galaxy Keywords.”
Galaxy creates this file automatically the
first time you create a custom keyword or
category, and places it in the Preferences
folder in the System folder.
There may be times when you want to use
patches with attached custom keywords
on another computer. To make sure that
your custom keywords appear when you
use the other computer system, you need
to also copy your Galaxy Keywords file to
the new computer’s Preferences folder
(for System 7). If that computer already
contains a Galaxy Keywords file, you can
temporarily move it outside the System
folder while using your own Keywords
file.
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OVERVIEW
You find patches by entering patch information—patch names, patch comments,
and keywords—in a Find dialog box.
Galaxy supports two different levels of
Find methods:
•
•

General Find—for details, see Performing A General Find (pg. 71).
Specific Find—for details, see Performing A Specific Find (pg. 73).

No matter what type of patch information
you type in the Find dialog box, Galaxy
will search all three types of patch information (names, comments, and
keywords) for text that matches or contains the text you enter in the Find dialog
box.
To perform a General Find:
a Click within the Bank, Library, or
Bundle Window that you want to
search (making it the active window).

The method you choose depends on how
targeted you want your search to be.

NOTE: If you don’t have a window open,
the Specific Find dialog box will open
instead of the General.

If you’ve followed this manual straight
through, you should have already
attached keywords and comments to
some of your own patches (see
Chapter 11: Cataloging Patches). Galaxy
also comes with over 1500 factory patches
with keywords already attached.

b Choose File>Find to open the

PERFORMING A GENERAL FIND

General Find dialog box.

c Type the patch name, comment, or
keyword for which you want to
search.
It doesn’t matter if you type upper or
lower case letters (case is ignored).
Also, you can type only part of a word or
comment.

When you perform a general find, only
the active Bank, Library, or Bundle is
searched.
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In the illustrations in this chapter, Galaxy
searches for patches that have the text
“viol” as a part of the patch information.
This means Galaxy will find patches that
have “viol” in its name, comments field, or
keywords list.
Figure 12.1: General Find Dialog Box

d Click the Find button.
The Find dialog box closes and Galaxy
searches its patch names, comments,
and keywords for text that matches the
text you entered in the dialog box. If the
text is a part of a name, comment, or
keyword attached to a patch, Galaxy will
find the patch and highlight it in the Bank
or Library where it’s located. If Galaxy
doesn’t find a match, the Macintosh will
beep.

For example, in addition to finding
patches called “Arco Violas,” “Arco Violins,” etc., Galaxy would also find a patch
called “Trem Strings,” which has the comment “La Traviatta: Violetta relinquishes
Alfredo” attached. Since the letters “viol”
are a part of the comment, Galaxy finds
the patch attached to that comment.

Figure 12.3: Patch Found Again

Figure 12.2: Patch Found

NOTE: If you want to stop a search in
progress, press command-(period). You
may have to hold down the key combination
for a few seconds before Find aborts.

e Choose File>Find Again to find the
next patch with a name, comment, or
keyword that contains the desired
text.
The Macintosh will beep when there are
no more patches with patch information
that matches your requirement.
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PERFORMING A SPECIFIC FIND
When you perform a Specific Find, you
can ask Galaxy to search a specific folder
or volume (if you’re using System 7). You
can also search all open windows or the
active Bundle, Bank, or Library.

To perform a Specific Find:
a Choose File>Find to open the
Specific Find dialog box.
Galaxy opens a Find dialog box that’s
the same type as the last box you
opened.

With the Specific Find option, you can
choose which field (names, comments, or
keywords) you want Galaxy to search. For
example, if you enter a name, then Galaxy
searches only for matching names; it does
not search the comment or keyword
fields. This streamlines the search process considerably.
Additionally, the Specific Find procedure
allows you to specify what you want
Galaxy to do with the patches it finds—
found patches can be highlighted one at a
time, or they can be cut or copied to new
Libraries.
IMPORTANT: You can’t perform a Find
(General or Specific) in a bulk-type file.
Also, if you are searching for a parent patch
type, Galaxy will not search or find
attached child patches.

Figure 12.4: Specific Find Dialog Box

If the General Find dialog box opens,
click the More Choices button in its
lower left corner.
The General Find dialog box is replaced
by a Specific Find dialog box similar to
the one shown in Figure 12.4.

Searching for Patch Names and/
or Comments
You can use the Specific Find dialog box
to search for a particular patch name, a
particular comment, or both.
b To search Patch names, click within
the name field and type the name you
want.
When you perform a Specific Find,
Galaxy searches patch names for a
string of characters that match those you
type (including punctuation). This means
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you can type part of a name if you want.
It doesn’t matter if you type upper or
lower case letters.

NOTE: Patch comments and how to create
them, are discussed in Chapter 11: Cataloging Patches.

Notice the check box to the left of the
word “Name” becomes checked after
you type in the “Name contains” field.
You can un-check the box if you decide
you don’t want Galaxy to search through
names.

Figure 12.6: Type a Patch Comment to Find

And/Or Options
Figure 12.5: Type a Patch Name to Find

c To search Patch comments, click
within the Comment field and type the
text for which you want to search.
When you perform a Specific Find,
Galaxy searches patch comments for a
string of characters that match those you
type (including punctuation). This means
you can type part of a word if you want. It
doesn’t matter if you type upper or lower
case letters.
Notice the check box to the left of the
word “Comment” becomes checked after
you type in the “Comment contains” field.
You can uncheck the box if you decide
you don’t want Galaxy to search through
Patch comments.
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If you type text into more than one field,
the And/Or pop-up menus appears to the
right of the Name and Comment fields.
Choosing one of these options becomes
an important additional factor in what
Galaxy finds.
d Click in the And/Or pop-up menu and
choose either “and” or “or.”
Choosing “and” instructs Galaxy to find a
patch only if both the Name and Comment search criteria are met.
Choosing “or” tells Galaxy to find a patch
if either the Name or Comment search
criteria are met.

For example, if you want to find a patch
that’s named “Viola” and contains the
comment “Scene 3, Cue 5” your search
will be more specific than if you want to
find a patch either named “Viola” or containing the comment “Scene 3, Cue 5.”
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Searching for Keywords
You can find patches by choosing one or
more keywords to define the desired
patch (or patches).
To search for specific keywords:
a Click the check box to the left of the
word “Keywords.”

NOTE: You can reorder words in the Categories and Keywords lists by Optiondragging the desired word to a new
location.
b Click a category to select it
(highlighting it).
Notice that Galaxy displays all of that
category’s associated keywords in the
Keywords list.

c Click a keyword to select it
(highlighting it).
Figure 12.7: Click the Keywords Check Box

Alternately, you could type ˚K.
Galaxy opens the Keywords to Find
dialog box.

Figure 12.9: Select a Category and a Keyword

d Click the topmost >>> button and
type the Return key to add the
keyword to the Find list.
Figure 12.8: Keywords to Find Dialog Box

You’ll see three list headings:
•

•

•

Categories—This lists all preset and
custom categories. When you select a
category, all the keywords in it are
displayed in the Keywords list.
Keywords—This lists all preset and
custom keywords assigned to a specific category.
Find—This is where you list all the
keywords you want included in a
search.
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Alternately, you could double-click the
selected keyword to add it to the Find
list.

Figure 12.10: Add Keywords to the Find List

e Continue to add as many keywords to
the Find list as you want (the list
scrolls).
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NOTE: Keywords from the same category
are initially grouped together in the Find
list, and are separated by the word “or.”
Keywords from different categories aren’t
necessarily grouped together, and are separated by the word “and.” See And/Or/Not
Options (pg. 76) for more information.

To remove the entire Find list:
a Click the Clear button located
beneath the Find list, or press the
Macintosh Clear key.

Figure 12.13: Clear List Button

Adding All Keywords to the Find List
To add all the keywords in the selected
category to the Find list:
a Select the category that contains all
the keywords you want to find.

b Click the All>>> button.

And/Or/Not Options
You can alter the way Galaxy performs a
keyword search by using the and, or and
not buttons. Specifically:
•

Figure 12.11: Add All to List Button

c Notice that Galaxy added all the
keywords to the Find list.
Also notice that the keywords are separated by the word “or” since they’re from
the same category.

Removing Keywords from the Find List
To remove a keyword from the Find list:
a In the Find list, click the keyword you
wish to remove.

b Click the Rmv (Remove) button, or

•

Use the and button if you want
Galaxy to find patches containing a
specific group of keywords.
For example, if your Find list contains
the keywords “Violin” and “Bowed”,
and if the word “and” is between
them, Galaxy finds patches that contain only both keywords. Galaxy will
not find patches that contain only one
of the keywords.
Use the or button if you want Galaxy
to find patches containing any of a
group of keywords.
For example, if your Find list contains
the keywords “Violin” and “Cello”,
and if the word “or” is between them,
Galaxy finds all patches that contain
either the keyword “Violin” or the
keyword “Cello”.

press the Macintosh Delete or
Backspace key.

Figure 12.12: Remove from List Button
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•

Use the not button if you want Galaxy
to find patches that do not contain the
specified keyword.
For example, if your Find list contains
the keywords “Violin” and “Pizzicato”, and if the word “not” precedes
“Pizzicato,” Galaxy finds all patches
that contain the keyword “Violin” but
do not contain the keyword
“Pizzicato.”

The words “and” & “or” are used between
keywords. The word “not” is used in front
of keywords.
To use the and, or, and not buttons:
b Click to select a keyword
c Click the and, or, or not button.
If the selected keyword is already prefaced by the word “not,” clicking the not
button removes the word “not.”

For a detailed example of using the and,
or, and not buttons see And/Or/Not
Example (pg. 78).

Look at the example shown in
Figure 12.14.

Figure 12.14: Sample Find List

Galaxy first groups the “or” keywords into
the following set:
•

Galaxy then applies all the “and” functions
to keywords or groups of keywords:
•

•
•

Galaxy first groups all “or” keywords
(from the top of the list to bottom).
Galaxy next evaluates all “and” keywords (from the top of the list to the
bottom).
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(Aggressive) and (not Distorted)
and (Electric Guitar or Electric
Bass).

So, when Galaxy searches your patches, it
finds two types:
•

And/Or Hierarchy
It’s important to realize the order in which
Galaxy groups the “and” & “or” keywords. Specifically:

(Electric Guitar or Electric Bass)

•

Those patches that contain both the
“Aggressive” and “Electric Guitar”
keywords, but not the “Distorted”
keyword.
Those patches that contain both the
“Aggressive” and “Electric Bass” keywords, but not the “Distorted”
keyword.
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And/Or/Not Example
Follow through this exercise to learn how
to use the and, or, and not buttons to set
up the Find list shown in Figure 12.14:
a Select the Tone Color category and
add the keywords “Aggressive” and
“Distorted” to the Find list.
Galaxy automatically puts an “or”
between the keywords since they’re from
the same category (as shown in
Figure 12.15).

Figure 12.16: Selecting Guitar Keywords

c Since you want only patches that are
not distorted, click “Distorted” in the
Find list to select it.

Figure 12.17: Selecting “Distorted” in the Find
List

d Click the not button.
Figure 12.15: Selecting Tone Color Keywords

b Select the Guitars category and add
the keywords “Electric Guitar” and
“Electric Bass” to the Find list.
Galaxy joins the first new keyword to the
last keyword with an “and” (since these
keywords are from different categories).
Galaxy joins the second new keyword to
the first with an “or” since they’re from
the same category. See Figure 12.16.

Notice that the keyword “Distorted”
becomes “not Distorted” as shown in
Figure 12.18.

Figure 12.18: Adding “Not” To aKeyword

e Since you want patches that contain
the word “Aggressive” and do not
contain the keyword “Distorted,” click
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“Aggressive” in the Find list to select
it.

Figure 12.19: Selecting “Aggressive” in the
Find List

f Click the and button.
Notice that the Find list changes from
“Aggressive or...” to “Aggressive and...”
as shown in Figure 12.20.

b Type a name for the list in the dialog
box that appears.

Figure 12.22: Save the Find List as a Keyword

c Click OK to save the list as a
keyword.

To delete a keyword in the Macro
category:
a Select the keyword
b Click the Delete button, which
appears to the left of the Save button
when the Macro category is selected.

Figure 12.20: Changing an “Or” to an “And”

Saving the Find List as a Macro
If you frequently use the same list of keywords to find patches, you can save the
entire list as a keyword in the Macros category. You can name this list whatever
you like.
To save the Find list as a keyword in the
Macro category:
a Click the Save button, located
beneath the Find list.

Figure 12.21: Save List Button
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Exiting to the Specific Find Dialog Box

Choosing Where to Search

After you’ve selected some keywords,
click the OK button to exit the Add Keywords dialog box and return to the
Specific Find dialog box.

Use the “Where To Search” radio buttons
to tell Galaxy which Banks, Libraries, or
Bundles to search.

Figure 12.25: The “Where To Search” Radio Buttons

Click the radio button for either all open
windows or this bank/library/bundle.
If you choose file/folder, click the
labeled button (not the radio button).

Figure 12.23: Keywords Used in the Find Procedure
are Displayed

NOTE: If you’re running System 7, you can
search an entire drive by clicking file/
folder then specifying the drive to search.
Searching This Bank/Library/Bundle

Choosing a Patch Type to Find
Use the Patch Type pop-up menu to tell
Galaxy to either:
•
•

search for a patch of any type, or
search only for a patch of a specified
type.

If you select this bank/library/bundle
and click the Find button, Galaxy
searches the currently active Bank,
Library, or Bundle Window.
Searching All Open Windows
If you select all open windows and click
the Find button, Galaxy searches all open
Bank or Library Windows.
Searching a File/Folder

Figure 12.24: Patch Type Pop-Up Menu

The Patch Type pop-up menu displays all
the patch types contained in your installed
Galaxy modules.
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If you select File/Folder, a dialog box
opens in which you can select the file or
folder you want to search. If you’re running System 7, you can also select a drive
to search.
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In the dialog box, click Open to open a
selected file or folder, or click Select to
choose a file or folder for searching. After
you click Select, the dialog box will close
and you’ll return to the Specific Find
dialog box.

When you click the Find button, Galaxy
locates the first patch matching your specifications and highlights it in its own Bank
or Library Window. To locate additional
patches that match your specifications,
you must choose File>Find Again.

Click Find to find the patches you’ve
specified in the file or folder you’ve
chosen.

If you perform a “one at a time” find on all
open windows, then close a window
before using Find Again, patches in the
window you closed won’t be found, but
you’ll still be able to find additional
patches in other open windows.

NOTE: This search method searches only
saved files; if you want to search an
unsaved Bank, Library, or Bundle you
must do a search of all open windows.
Once you’ve chosen a file to search, it
becomes the default file for your next File/
Folder search.

If you close a Bundle that contains Banks
that haven’t yet been searched, Find
Again will be disabled and the Find operation terminates unless there are other
open Banks or Bundles that haven’t been
searched.

Choosing a Search Type
Use the Search Type radio buttons to tell
Galaxy what you want it to do when it
finds patches that match your selection
criteria. Each of the three options is discussed in the following sections.

Cut to New Library
If you select cut to new library and click
the Find button, Galaxy finds patches and
cuts them from the Bank or Library in
which they’re located, and places them in
a new Library.

Figure 12.26: The “Search Type” Radio Buttons

One at a Time
If you select one at a time and click the
Find button, Galaxy finds patches by
highlighting them in the window in which
they’re located.
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Figure 12.27: Found Patches Cut to a New Library
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If Any Type is selected as the patch type,
different patch types are placed in different Libraries.
IMPORTANT: Cutting patches to a new
Library cannot be undone.
If you are performing a file/folder search,
and patches are found and cut from a file
that was not previously open, Galaxy will
attempt to save and close the file. Galaxy
will, however, ask you if you want to save
changes.

If you asked Galaxy to find patches one at
a time, and you want to find another patch
that meets the same criteria:
b Choose File>Find Again.
To stop a current search:
c Press the command and period keys
together.
You may have to hold down the keys for
a few seconds before Find aborts.

Copy to New Library
If you select copy to new library and
click the Find button, Galaxy finds
patches and copies them from the Bank
or Library in which they’re located, and
places them in a new Library. The new
Library is given the title “Found:[patch
type]”.
If Any Type is selected as the patch type,
different patch types are placed in different Libraries.

Finding the Patch You’ve
Specified
To find patches that meet the criteria you
specify in the Specific Find dialog box:
a Click the Find button.
.

Figure 12.28: Find Button
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New Bundle
Choose this command to create a new
Bundle.
If you don’t have any saved Bundle Templates, choosing New Bundle causes
Galaxy to open a Select Device dialog
box.

Figure 13.1: File Menu

Use the File menu commands to save,
create, open, print, and search the various
files created by Galaxy. The following sections discuss each File menu command
(from the top of the menu to the bottom).
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Figure 13.2: Select Device Dialog Box

From the scrolling list, select the
device(s) you want included in your new
Bundle (shift-click to select multiple
devices), then click the OK button. For
more information, see Creating a New
Bundle (pg. 25).
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NOTE: If you installed only a single Librarian Module into Galaxy, and that module
works with only a single device, then
Galaxy opens a new, untitled Bundle
Window without producing the Select
Device Dialog Box.

New Bank
Choose this command to create a new
stand-alone Bank. When you choose New
Bank, Galaxy displays a New Bank dialog
box similar to the one shown in
Figure 13.4.

Bundle Templates
If you’ve created Bundle Templates,
choosing New Bundle opens a Select
Template dialog box similar to the one
shown in Figure 13.3.

Figure 13.4: New Bank Dialog Box

The New Bank dialog box lists all the
Bank types for all the devices supported
by the Librarian Modules you installed
into Galaxy.
Figure 13.3: Select Template Dialog Box

From the scrolling list, select the desired
Bundle type, then click the OK button.
Galaxy opens a new Bundle Window that
matches the template.
If you choose “Empty Bundle” from the
Select Template dialog box, Galaxy opens
the Select Device dialog box as described
in New Bundle (pg. 85).
For more information about Bundle Templates, see Creating Bundle Templates
(pg. 32).
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From the scrolling list, select the type of
Bank you wish to create, then click the
OK button. Galaxy opens a new Bank
Window of the selected type.
NOTE: If you’ve installed only a single
Librarian Module that supports only a
single device, Galaxy will create a new
Bank without opening the New Bank
dialog box.
Stand-alone Banks are discussed in detail
in Chapter 7: Stand-Alone Banks.
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New Library

Open

Choose this command to create a new
Library. When you choose New Library,
Galaxy displays a New Library dialog box
similar to the one shown in Figure 13.5.

Choose this command to open an existing
Galaxy file. When you choose Open,
Galaxy displays an Open dialog box similar to the one shown in Figure 13.6.

Figure 13.6: Open Dialog Box

The dialog box contains two scrolling
lists:
Figure 13.5: New Library Dialog Box

A dialog box opens showing all the possible Library types. The list is based on the
Librarian Modules you installed into
Galaxy.
From the scrolling list, select a Library
type, then click the OK button. Galaxy
opens a new Library Window of the
selected type.

•

•

Patch Type: This left-hand list contains a list of all patch types supported
by the Librarian Modules you’ve
installed into Galaxy.
Files: This right-hand list functions
much like a standard Open dialog box
and lists all files of the type selected
in the left-hand list.

Libraries are discussed in detail in
Chapter 8: Libraries.
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Opening a Bank or Library

Close

To open a a stand-alone Bank or Library:

Choose this command to close the active
window. If you have not made any
changes, Galaxy closes the window
immediately.

a From the Patch Type list (left-hand
side), select the patch type you wish
to open.

b Use the Files list (right-hand side) to
find and select the file you wish to
open.

If you have made changes, Galaxy asks if
you want to save the changes.

The Files list shows only the files that are
of the type selected in the Patch Type
list.

c Click the Open button.
Opening a Bundle
To open a Bundle:

Figure 13.7: Save Changes Dialog Box

a From the Patch Type list (left-hand

•

side), select “Bundle.”

b Use the Files list (right-hand side) to

•

find and select the Bundle you wish to
open.
The Files list shows only Bundles, not
stand-alone Banks or Libraries.

If you click Discard, the document
closes and all changes are discarded.
If you click Save, the document
closes after first saving the changes.
If the window is untitled, you’ll be
asked to name the file before saving
it.
If you click Cancel, the window will
not close.

c Click the Open button.

•

All Patch Types

Clicking an active window’s Close box is
the same as choosing the Close
command.

Check the All Patch Types option if you
want the Files list to display all Bundle,
Bank, and Library files.
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Save
Choose this command to save a file using
the same name and folder with which you
saved it last.
If the file has never before been saved,
Galaxy asks you to name it and find a
folder in which to store it (as if you had
chosen the Save As command).
Galaxy disables the Save command if you
haven’t changed the file since opening it.

Figure 13.8: Save As Dialog Box

If a bundled Bank Window is active when
you choose Save, Galaxy saves both the
Bank and the Bundle containing it.

This is a standard Macintosh Save As
dialog box. To save a file, type the desired
name into the text field, select a folder,
and click the Save button.

Save As

If a bundled Bank Window is active when
you choose Save As, Galaxy saves both
the Bank and the Bundle containing it.

Choose this command to:
•
•
•

Save an existing document under a
new name.
Save an existing document to a new
folder or volume.
Save a new document.

When you choose the Save As command,
Galaxy produces a Save As dialog box
similar to the one shown in Figure 13.8.
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Save And Make Current
Choosing this command makes the
Bank/Bundle occupying the front-window
position the Current Bank/Bundle as
defined by OMS Name Manager. This
enables Vision or other OMS 2.0 compatible applications using the OMS Name
Manager to refer to patches in the current
Bank/Bundle by name. Several Bundles
containing the same device type may
become current as long as their device
IDs are different.
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Print

Find

Choose this command to print the contents of an entire Bank or Library file,
including all patches not currently visible
on the screen. If the topmost window is a
Help Window, choosing Print will print
the help text.

Choose this command to open either a
General Find dialog box or a Specific Find
dialog box. A General Find searches all
types of patch information (patch name,
keywords, comments) for a matching text
string. A Specific Find allows you to:

IMPORTANT: Printing will not work if
you’re printer requires AppleTalk and
you’ve disabled it using OMS.
To print:
a Choose File>Print.
Galaxy opens a standard Macintosh
Page Setup dialog box.

b Select your desired page setup
options, then click the OK button.
Galaxy open a standard Macintosh Print
dialog box.

c Select the number of copies you want

•
•
•

Fine-tune your search to specific
types of patch information.
Perform boolean logic operations
with your find selections.
Determine what you want Galaxy to
do with the patches it finds.

If you see a General Find dialog box, you
can open the Specific Find dialog by clicking the More Choices button. If you see
a Specific Find dialog box, you can open
the General Find dialog box by clicking
the Fewer Choices button. Find operations are discussed in detail in
Chapter 12: Finding Patches.

to print, then click the Print button.
Galaxy prints all the pages in the file
(regardless of how many pages you
asked it to print).

NOTE: If the same port is used for both a
MIDI interface and the printer (and you
are not using a MIDI interface with Thru
switches), you must disconnect the MIDI
interface before using the Print command.
Printing is discussed further in Print the
Contents of a Bank or Library (pg. 52).
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Find Again
Choose this command to continue finding
patches with the characteristics specified
in either the General Find or Specific Find
dialog boxes. See Chapter 12: Finding
Patches for more information.

Export to Clipboard
Choose this command to export a patch
or a Bank to the Clipboard in MIDI File
format. You can then paste the MIDI File
into another MIDI application (if that
application supports pasting MIDI Files
from the Macintosh Clipboard).
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From Galaxy, you can export:

In Galaxy:

•

a Open a stand-alone Bank Window or a

•

Individual patches from stand-alone
or bundled Banks.
Individual or multiple Banks from
Bundles (you cannot export standalone Banks).

bundled Bank Window.

b Select one patch.
c Choose File>Export to Clipboard.
Galaxy exports the patch to the Clipboard as a MIDI File (format 1).

When you export Galaxy data to the Clipboard, it creates a multitrack MIDI File
(format 1). The MIDI File’s track arrangement depends on what you export:
Generally, data from each device is stored
in a separate MIDI File track. Therefore:

In Vision:

•

b Choose Edit>Paste.

•

If you export data (patches or Banks)
from a single device, you create a
MIDI File with a single track.
If you export data from multiple
devices, you create a MIDI File with
the same number of tracks as
devices.

The following sections provide examples
of how to:
•
•

export single patches and paste them
into Vision.
export entire Banks and paste them
into Vision.

a Select a track by clicking its selector
dot in the Tracks Window.
Vision pastes the system exclusive data
into the selected track.

Figure 13.9: Patch Pasted into a Vision Track

As an alternative, you can paste the MIDI
File to its own sequence—Vision automatically creates a single track for the data.

Example 1: Exporting Patches
When you’re exporting patches rather
than entire Banks, you must export them
one at a time. If you select multiple
patches and try to export them simultaneously, Galaxy exports only the first one
you selected.
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Example 2: Exporting Banks
Follow through this example to learn how
to transfer entire patch banks of system
exclusive data from Galaxy into Vision.
In Galaxy:
a Select one or more Banks in a Bundle.

b Choose File>Export to Clipboard.
You’ll see a progress dialog box while
Galaxy copies the selected Banks to the
Clipboard in MIDI File format.

In Vision:
a Select as many tracks as devices
containing selected patch Banks.
For example, if you exported all four
Banks in a Proteus/1 and all four Banks
in a Proteus/2, you would select two
tracks in Vision (since you have two
devices).

If you want to select all the Banks for a
device, simply click the device information line in the Bundle Window.

Figure 13.10: Select as Many Tracks as
Devices

NOTE: If you have multiple identical
devices in a Bundle and you select Banks
from each device, you should select tracks in
Vision for each device. For example, say
you have two M1’s and you select a Bank
from each of them, then you should select
two tracks in Vision.
b Choose Edit>Paste Tracks.

If you want to select multiple devices,
shift-click their names in the Bundle
Window.
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Galaxy pastes the system exclusive data
from the Banks into the selected tracks.
The length of the track is determined by
the amount of data; different patch types
contain different amounts of data. Each
track’s Instrument is named automatically for each exported device.
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Possible Problems When Exporting
You should be aware of the following
points when using Galaxy’s Export To
Clipboard command:
Figure 13.11: Clipboard Pasted to Selected
Vision Tracks

As an alternative, you can paste the MIDI
File to its own sequence—Vision automatically creates a track for each device.

•

•

Viewing The Exported Data In Vision
You can view the system exclusive data in
Vision’s List Window.

Figure 13.12: Sys-ex Data as Viewed in Vision’s List
Window

•

IMPORTANT: It’s OK to change the start
time of an entire group of sys-ex messages,
but NEVER change the time BETWEEN
sys-ex messages. These times are very specific and unique to each synthesizer.
•
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Device ID and Sys-ex Channel
Do not change a MIDI device’s ID
number after importing sys-ex data
into a sequencer.
Exporting Multitimbral Type Patches
You can’t always export a multitimbral setup patch to the Clipboard and
expect your sequencer to playback all
the correct patches. For this to work,
you need to make sure that sending a
multitimbral setup to your synthesizer pulls referenced single patches
into their edit buffers, and that the
correct single patches are in the synthesizer. It should work if the patch
type supports sending of attached
patches; a few Galaxy modules do
this (read the on-line help to find out
if a module does or not), but in most
cases, you should export whole Bundles and avoid exporting individual
multitimbral setups.
Handshaking
Some devices require two way communication (handshaking) during
patch sends. Exporting patches of
these types will usually not work
since Vision cannot respond to handshaking messages.
Patcher Program Changes
Patcher program changes are not
included in exported sys-ex data.
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•

•

Not Enough Memory
Sys-ex data can require a large
amount of memory. If your computer
doesn’t have enough RAM, you may
not be able to export patches or
banks.
Eccentricities of Data Transfers
Any eccentricities that occur when
you send data to a MIDI device from
Galaxy will also occur if the patch or
Bank is exported and played back in a
sequence.

Quit
Choose this command to close all windows and quit Galaxy. If you have any
unsaved documents open when you
choose Quit, Galaxy asks you whether or
not you want to save each unsaved file.
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For most operations, Galaxy uses an internal Clipboard (not the Macintosh
Clipboard). The contents of the internal
Clipboard are not available to other programs. If, however, you use the Copy
Names command from a Bank or Library
(but not from a Bundle), patch names are
saved on the Macintosh Clipboard, and
are available to other programs.

Undo
Undo reverses the effect of your last command or action. The command to be
undone is shown as part of the Undo
menu command. After undoing a command, you can always redo it—the menu
item becomes Redo.

Cut
Figure 14.1: Edit Menu

Use the Edit menu commands for
moving patches either within or between
windows. Edit commands use the Clipboard concept common to most
Macintosh programs. However, patches
on the Clipboard are not saved when you
exit Galaxy; all patches must be saved in
Bank, Bundle, or Library files.
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Choose this command to move the
selected items from the active window to
Galaxy’s Clipboard. It’s the same as
choosing the Copy command followed by
the Clear command.
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Copy

Clear

Choose this command to copy the
selected items from the active window to
Galaxy’s Clipboard. The window remains
unchanged.

Choose this command to delete the
selected items from the active window.
This command does not affect Galaxy’s
Clipboard. If you clear a patch from a window, Galaxy replaces it with an empty
patch, which you can define using the Set
Empty Patch command as discussed in
Set Empty Patch (pg. 99).

Paste
Choose this command to copy the items
from Galaxy’s Clipboard to the active
window.

Select All

If you’re pasting to a Bank, Galaxy pastes
items into the locations you select. If
you’ve selected fewer locations than the
number of items on the Clipboard, Galaxy
won’t paste some of the items. If you’ve
selected more locations than the number
of items on the Clipboard, Galaxy won’t
fill some of the locations.

Choose this command to select all of the
patches in the active Bank Window or
Library Window. This command is useful
when you want to copy entire Banks into
Libraries.

If you’re pasting to a Library, Galaxy adds
the entire contents of the Clipboard to the
Library. If a pasted patch has either the
same name or same patch data as an
existing Library patch, you’ll see a dialog
asking you to rename a patch or remove
one of the duplicates. For more information, see Patch Names in a Library
(pg. 45) and Avoiding Duplicate Patches
(pg. 46).

This command is related to the Testing
Sounds command. For more information,
see Testing Sounds (pg. 97).
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Testing Sounds
Galaxy can use the Macintosh keyboard
in one of two ways—either to type patch
names or to send notes to your MIDI
device.
You can select how you want to use the
Macintosh keyboard by checking either
the Enter Names or Testing Sounds
options.
•

•

If you check Testing Sounds, you’ll
be able to “play” the Macintosh keyboard without renaming patches.
This is useful if you want to “play” a
rack mount synthesizer module from
your Macintosh keyboard.
If you check Enter Names, you’ll be
able to enter patch names without
“playing” the MIDI device.

QWERTYU
ASDFGHJ
ZXCVBNM
Figure 14.2: “Playing” The Macintosh Keyboard

To enter names in Testing Sounds mode:
a Type an apostrophe, then type on the
Macintosh keyboard.
The apostrophe tells Galaxy that you
want to edit a patch name rather than
play it from the Macintosh keyboard.

To enter and use Testing Sounds mode:

To enter and use Enter Names mode:

a Select Edit>Testing Sounds to

a Select Edit>Enter Names to place a

place a check mark next to the option.

b “Play” your Macintosh keyboard.
As shown in Figure 14.2, the 21 left-most
letter keys (three rows: Q-U, A-J, and
Z-M) correspond to three octaves of
white keys. The Z key is middle C. If you
press the Shift or Caps Lock Key, the
note will be shifted down three octaves.
You can not play the black piano keys
from the Macintosh keyboard. Set the
note velocities with the MacKV control in
the MouseKeys Window. For more information, see Chapter 10: Auditioning
Patches. Pay particular attention to Macintosh Keyboard Velocity Control
(pg. 61) and “Playing” the Macintosh
Keyboard (pg. 62).
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check mark next to the option.

b Click a patch name to select it and
type a new name.
In this mode, you don't need to type an
apostrophe before editing a name. The
Macintosh keyboard will never be used
to “play” the MIDI device.

Copy Names
Choose this command to copy the names
(in text format) from a Bank Window or
Library Window to the Macintosh Clipboard. You can then paste the names into
any text editing program to customize
patch lists.
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If you copy names from a Library, Galaxy
copies the names to the Macintosh Clipboard alphabetically.
If you copy names from a Bank, Galaxy
copies the names to the Macintosh Clipboard in the order they appear in the
Bank Window.

Choose the Delete Duplicate Patches
command to purge a Library of all duplicates. Whenever duplicates are found, the
names of all the duplicate patches are displayed, and you are given the opportunity
to listen to the patch and choose your
favorite name for that sound.

NOTE: You can also copy patch names into
a sequencer (like Vision) to see patch
names without subscribing to them through
OMS. However, because of OMS’s dynamic
and automatic features, you should always
use the OMS Names Manager to subscribe
to patch names whenever possible.

Delete Duplicate Patches
Choose this command to delete all
patches in a Library with duplicate
parameters.
It’s possible for your Libraries to contain
duplicate patches if you paste patches into
them with the No Duplicates in Library
option disabled in the Setup>Preferences dialog box.

This is the same dialog box that appears if
you try to paste a duplicate patch into a
Library with the No Duplicates in
Library option checked in the Preferences dialog box.
For a complete discussion of this dialog
box, see Avoiding Duplicate Patches
(pg. 46).

Delete Child Patches
When a Library or Bank Window is open,
choose this command to delete all child
patches attached to the currently selected
parent patch.
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Set Empty Patch

This menu item is enabled only if the
selected patch has attached child patches.

Choose this command to define your own
empty patch for a MIDI device. Galaxy
uses an empty patch in two situations:
•

•

When you open a new Bank, Galaxy
automatically fills the new Bank with
the empty patch.
When you clear a patch with the
Clear command, Galaxy replaces it
with the empty patch.

Generally, Galaxy uses an “initial patch”
defined by the MIDI device's manufacturer as the empty patch.
You can define your own empty patch by
choosing Set Empty Patch. When you
choose this command, Galaxy copies the
selected patch to the Galaxy Setup document and defines it as the empty patch for
that type of MIDI device.

Patch Info
Patch Info lets you view and assign
descriptive comments and keywords to
your patches. Once you’ve assigned this
information to a patch, it can be used as a
search criteria in the Find command. For
information on this menu item, see
Chapter 11: Cataloging Patches.

Figure 14.3: Child Patch Info Dialog Box

The Child Patch Info dialog box only displays information; if you’d like to edit
information, you’ll need to click the Edit
Info button to open the Patch Information
dialog box, where you can edit keywords
and comments.
NOTE: Many of the buttons in the Patch
Information dialog box are disabled when
you open it from the Child Patch Info dialog
box—therefore you should always open the
Patch Information dialog box using the
Patch Info command.

Child Patch Info
Child Patch Info is similar to Patch Info,
except it allows you to view and assign
comments and keywords for attached
child patches.
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Cross Reference Bank
Choose this command to see which
Parent Patches a Child Patch belongs to.
The command is available only when a
Bank Window is active.
When you choose this command, Galaxy
cross-references all the patches and displays them in a Cross Reference Window.

Figure 14.4: Typical Cross-Reference Window

The left columns of the Cross Reference
Window list Child Patches that are
attached to Parents. The right columns
display the name and location of those
Parents.
For example, look at Figure 14.4. It tells
us that:
•

•

•
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Voice #1: FILTERSYNTH is attached
to three Parent patches. These are
the Performance patches titled:
OBERSYNTH, SOLO LINE, and
SYNTHSPLIT.
Similarly, Voice #2: ANALOG is a
Child Patch of Performance #22:
SOLO LINE.
And so on, through a scrolling list of
Child Patches.
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The third menu from the left changes
depending on the type of window that’s
active:
•
•

•

If a Bundle Window is active, the
menu is a Bundle menu.
If a Bank Window or a Library
Window is active, the menu is a
Load/Send menu.
If no Bank Window or Library
Window is active, the menu is a
Setups menu. The Setups menu,
which is described in Chapter 16:
Setups Menu, gets pushed to the right
when the Load/Send or Bundle
menu is available.

This chapter discusses both the Bundle
menu and the Load/Send menu. The
actual commands in both menus may
change slightly depending on the MIDI
devices you use with Galaxy. This chapter
discusses those commands that are
common to all devices. Use Galaxy’s
on-line help to learn about commands that
may be unique to your specific MIDI
device. On-line Help is discussed in
Chapter 4: Using Galaxy’s On-Line Librarian Help.
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BUNDLE MENU
To make the Bundle menu accessible,
either open a Bundle Window or click in
an existing Bundle Window to make it the
active window.

Figure 15.1: Bundle Menu

The Bundle menu handles the transfer of
all patches between Galaxy and your
MIDI devices. You can use this menu to
specify exactly which MIDI devices and
Banks the Bundle contains, and also to
save and delete Bundle Templates.
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Get All Banks from (Device)

Get All Banks in Bundle

Choose this command to make the
selected MIDI device transfer all its internal Banks into corresponding Banks in
Galaxy’s Bundle Window.

To get all Banks from your MIDI device:

Choosing this command causes each
MIDI device in your Galaxy Bundle to
transfer its internal Banks into
corresponding device Banks in the active
Bundle Window. Make sure all Bank
types included in the Bundle mirror the
Bank types actually in your devices.
Unlike Get All Banks from (Device),
this command “gets” Banks from every
MIDI device in the Bundle, regardless of
which device you selected.

a Open a Bundle Window.
b Click a device in the Bundle Window

Send All Banks to (Device)

NOTE: Your MIDI device transfers only the
Banks selected in the Banks in Device
dialog box, discussed in Banks in Device
(pg. 103).

to select it (highlighting it).

Choose this command to make Galaxy
send all Banks to the selected MIDI
device.
IMPORTANT: Choosing this command
replaces all the internal RAM patches in
your MIDI device with those stored in
Galaxy.
To send all Banks to your MIDI device:

c Choose Bundle>Get All Banks
from (Device).
Galaxy will “get” all the requested Banks
from the selected MIDI device and place
them in the Bundle.

102

a Open a Bundle Window.
b Click a device in the Bundle Window
to select it (highlighting it).

c Choose Bundle>Send All Banks to
(Device).
Galaxy sends all the device-related
Banks from the Bundle to the selected
MIDI device.
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Send All Banks in Bundle
Choosing this command causes Galaxy to
send all Banks in the active Bundle to the
corresponding MIDI devices. Unlike
Send All Banks to (Device), this command sends Banks to every MIDI device
in the Bundle, regardless of which device
you selected.
IMPORTANT: Choosing this command
replaces all the internal RAM patches in
your MIDI devices with those stored in
Galaxy.

Add Device

Add MIDI devices to the active Bundle
Window by clicking the device, then clicking the OK button. You can add multiple
devices by shift-clicking their names.
For more information, see Creating Bundles with Multiple Devices (pg. 31).

Banks in Device
Choose this command to select which
Bank types to include in the Bundle.
When you choose the Banks in Device
command, Galaxy opens the Banks in
Device dialog box.

Choose this command to add devices to
your Bundle. When you choose the Add
Device command, Galaxy opens a Select
Device dialog box exactly like the one
opened by the New Bundle command
discussed in New Bundle (pg. 85).

Figure 15.2: Banks in Device Dialog Box for a
Proteus Sound Module

The dialog box lists all possible Bank
types for the selected device. Check those
types you want included in the Bundle.
When you check a Bank type, Galaxy
adds that Bank to the Bundle. When you
un-check a Bank Type, Galaxy deletes
that Bank from the Bundle. Therefore,
make sure you save anything valuable
before un-checking a Bank.
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For a tutorial using the Banks in Device
command, please see Choosing the Banks
You Want in the Bundle (pg. 29).
IMPORTANT: Galaxy remembers your
Bank choices for each device type. The next
time you add that device to a Bundle,
Galaxy includes only those Banks you chose
in the Banks in Device dialog box.

Remove Device
Choose this command to remove the
selected device from the active Bundle
Window. This means that all Banks in the
selected device are deleted. If the Banks
are valuable, be sure you save them
before choosing this command.

Delete Template
Choose this command to delete a Bundle
Template from your Galaxy Setup file. See
Deleting Bundle Templates (pg. 33) for
details about deleting Bundle Templates.

View By Name
View By Icon
The name of this command changes
depending on which mode Galaxy is in.
•

•

Save As Template
Choose this command to save the structure of the active Bundle as a template, or
model, for new documents. This command does not save the actual patch data;
only the Bundle’s structure. Specifically, a
Bundle Template saves a list of devices in
a Bundle and a list of Banks for each of
those devices.

If Galaxy currently displays Bank
icons in a Bundle Window, choose
View By Name to see only Bank
names (not icons) in a Bundle
Window.
If Galaxy currently displays only
Bank names in a Bundle Window,
choose View By Icon to see both
Bank names and icons in a Bundle
Window.

For more information, see Viewing the
Bank List (pg. 28).

For a tutorial using the Save As Template command, please see Creating
Bundle Templates (pg. 32).
Bundle Templates are saved in the Galaxy
Setup file. They are not saved with the
Galaxy program.
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LOAD/SEND MENU
To make the Load/Send menu accessible, open either a Bank Window or
Library Window, or click in an existing
Bank or Library Window to make it the
active window.

Get (Patch) from (Device)
Select a location in a Bank Window into
which you want to load an individual
patch, then choose the Get (Patch) from
(Device) command. Galaxy asks the
device to send it the requested patch data.
All devices respond to this request
differently:
•
•

Figure 15.3: Load/Send Menu

Use the Load/Send menu commands to
transfer patches and/or Banks between
the MIDI device and the Macintosh. The
actual commands in the Load/Send
menu vary according to the type of
device, the patch type, and whether the
active window is a Bank or Library. See
the on-line help for your device to learn
about Load/Send commands specific to
your MIDI devices.
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Most MIDI devices simply send
Galaxy the requested data.
Some devices may not respond to
Galaxy’s request. For these devices,
Galaxy produces a dialog box that
tells you exactly what buttons to push
on your MIDI device to initiate the
patch transfer.

Look at Galaxy’s on-line help for more
information about your specific device.
NOTE: The Get (Patch) from (Device)
command is disabled when a Library
Window is active. To fill a Library with
patches, use either the option-drag method
or standard Macintosh cut/copy/paste techniques. See Filling a Library (pg. 43) for a
detailed tutorial.
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Send (Patch) to (Device)

Get Bank from (Device)

Choose this command to send a selected
patch from a Bank Window to your MIDI
device. Different MIDI devices (and patch
types) respond differently:

This command causes Galaxy to ask your
MIDI device to send its entire bank of
patches to the active Bank Window. All
devices respond to this request
differently:

•

•

If your device has an edit buffer for
the selected patch, then Galaxy sends
the patch to the edit buffer.
If your device doesn’t have an edit
buffer for the selected patch, then
Galaxy usually sends the patch to the
highest numbered patch location.
This is true only for timbral patches
(as opposed to non-timbral patches
like program change tables).

Look at Galaxy’s on-line help for more
information about your specific device.
NOTE: The Send (Patch) to (Device)
command is disabled when a Library
Window is active. To send a patch from a
Library, check Send on Select (in the
Load/Send menu), then click patch
names to send them.

•
•

Most MIDI devices send Galaxy the
requested data.
Some devices may not respond to
Galaxy’s request. For these devices,
Galaxy produces a dialog box that
tells you exactly what buttons to push
on your MIDI device to initiate the
patch transfer.

Look at Galaxy’s on-line help for more
information about your specific device.
NOTE: If your MIDI device doesn’t support
patch names, Galaxy will either leave the
names blank or assign a default name
(such as “unnamed”).

Send Bank to (Device)
This command sends an entire bank of
patches from the active Galaxy Bank
Window to your MIDI device. Different
MIDI devices (and Bank types) respond
differently:
•
•

106

Most MIDI devices fill their Bank
with the new patches.
Some devices may not respond
directly to the data Galaxy sends. For
these devices, Galaxy produces a
dialog box that tells you exactly what
buttons to push on your MIDI device
to enable it to receive the patch data.
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Look at Galaxy’s on-line help for more
information about your specific device.

Send on Select
This option controls whether or not
Galaxy sends patches to your MIDI
devices automatically. You can either
enable (check) or disable (un-check) this
option.
•

•

Enabled (checked): Any time you
select a patch, Galaxy sends that
patch to your MIDI device automatically. When you select a patch with
this option checked, it’s just as if you
selected a patch and chose the Send
(Patch) to (Device) command.
Disabled (un-checked): You must
send selected patches to MIDI
devices manually (by choosing the
Send (Patch) to (Device)
command).

NOTE: You must check the Send On
Select option to send patches from a
Library to your MIDI device. You must also
select this option if you want to use the
Play>Play on Select option. For more
information about the Play on Select
command, see Playing Sequences (pg. 62).
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Galaxy Configuration
Choose this command if you want to manually install Librarian Modules into
Galaxy.

Figure 16.1: Setups Menu

The Setups menu is available either
when there are no windows open, or
when a Bundle, Bank, or Library Window
is open. It is not available if an Editor
Window is active.
Use the Setups menu to configure Galaxy,
to access OMS setups, and to set up controllers and remote control functions.

Figure 16.2: Typical Galaxy Configuration Dialog Box

NOTE: This command will not install
Editor Modules into Galaxy Plus Editors. If
you wish to manually install Editor Modules, you must install them from your
master disks to the Galaxy Editors folder on
your hard disk. The Galaxy Editors folder is
in the same folder as the Galaxy
application. For detailed information
about installing Editor Modules, see Installing Galaxy (pg. 10)
For detailed information about using the
Galaxy Configuration command, see
Galaxy Configuration (pg. 13).
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About the Galaxy Configuration Dialog
Box

Preferences

The information contained in the scrolling
list changes depending on which radio
button you choose:

Choose this command to open the Preferences dialog box. Use this dialog box to
configure numerous global settings for
Galaxy.

•

•

Devices: If you click this radio button
(as shown in Figure 16.2), the scrolling list shows every type of device
supported by the Librarian Modules
currently installed in Galaxy. The list
is empty if there are no installed
modules.
If the list shows devices you don’t
own, it’s because many Galaxy Librarian Modules support more than one
type of device. For example, the
Yamaha TX81Z/DX11/DX21 Librarian works with TX81Z, DX11, DX21,
DX27, and DX100 synthesizers—
therefore all these devices show up in
the scrolling list.
Patch Types: If you click this radio
button, the scrolling list shows every
type of Patch Bank supported by
every Librarian currently installed in
Galaxy. The list is empty if there are
no installed modules.

NOTE: Use the Programming Mode
checkbox if you wish to create your own
Librarian Module with PatchTalk. When
the Programming Mode option is
selected, A Custom menu containing
PatchTalk commands will be visible. The
PatchTalk Manual is available in electronic form in the Galaxy Extras folder.
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Figure 16.3: Preferences Dialog Box

As you can see in Figure 16.3, the Preferences dialog box contains numerous
elements. These are described, below:
A

Window at startup: Use this option
to specify which Galaxy window you
want to open each time you launch
the program. You can choose
between a new Bank, a new Bundle, a
new Library, an Open dialog box, or
no window. Click the radio button
next to the option you prefer.
B No Duplicate Patches in Libraries: Check this option when you’re
pasting patches to a Library and you
don’t want that Library to contain any
patches with duplicate patch parameters (even though they may have
different names). When you select a
patch to paste into a Library, Galaxy
checks actual patch parameters of
that patch against the patch parameters of all patches currently in the
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Library. So even if patches have different names but duplicate
parameters, you’ll be notified. For
more information, see Avoiding
Duplicate Patches (pg. 46).
C Ignore Name in Duplicate Check:
If you check this option, Galaxy
ignores patch names when searching
for duplicate patches. This is useful if
you’re pasting a patch with the same
name as one patch and the same
parameters as another and don’t want
to be bothered by dialog boxes.
When this option is un-checked, you
will have to enter a new name in one
dialog box, then choose a name to
keep in another dialog box. When
checked, Galaxy will ignore the patch
without producing any dialog boxes.
See Avoiding Duplicate Patches
(pg. 46) for more information.
D Hide Windows in Multifinder
Check this option if you want Galaxy
to hide all of its windows when you
switch to another application.
E Provide patch names for
pre-OMS 2.0 applications: Check
this option if you’re using Galaxy with
a MIDI application designed to work
OMS 1.x.
Vision previously handled the
inter-application name management
tasks that are now part of OMS 2.0. If
you’re using a pre-OMS 2.0 version of
Vision, you can check this option to
have Galaxy provide it with patch
names. There’s no need to check this
option if all your MIDI applications
support OMS 2.0.
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F

Provide controller names for
OMS 2.0 applications: With
OMS 2.0, you can name MIDI controllers. This is convenient if you’re
controlling various synthesizer
parameters with customized MIDI
controllers. You can name the controllers and, if you check this option,
your custom controller names will
appear in all other OMS 2.0
applications.
G Auto-scan/Install Librarians:
Librarian modules for all supported
devices are installed into the Galaxy
Librarians folder on your hard disk
during automatic installation of
Galaxy. However, since each user
normally utilizes only a few modules,
these may be individually installed
into Galaxy in two different ways.
When the Auto-scan/Install Librarians option is selected, Galaxy
detects and installs any devices in the
current OMS Studio Setup document
that do not yet have their corresponding Librarian modules installed.
When Auto-scan/Install Librarians is not selected, you must install
individual modules using the method
discussed in Drag and Drop Librarian
Installation (pg. 12).
H Auto-rename uses: When you paste
patches into a Library with duplicate
names, Galaxy gives you the option of
renaming patches automatically. Use
the Auto-rename uses radio buttons
to select which ending you’d like
appended to patch names automatically. For more information, see Patch
Names in a Library (pg. 45).
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I

Middle C is: Use these radio buttons
to select whether you want Galaxy to
name middle C as “C3” or “C4.” This
affects the way MouseKeys and
Editors display MIDI note names.
The MIDI Standard specifies that
Middle C (MIDI note number 60) is
named “C4.” Yamaha and some other
synthesizer manufacturers actually
give Middle C the name “C3.”
J PatchTalk Delay: This numerical
slows down MIDI communications
with your devices. You should leave
this numerical set to 0 unless your
synthesizers give you MIDI buffer
overflow messages. If this happens,
try increasing this numerical 10 ticks
at a time until the problem
disappears.

Enable Input Devices
Choose this command to open the Enable
Input Devices dialog box. This dialog box
contains a scrolling list of all devices in
your current Studio Setup document.

Figure 16.4: Enable Input Devices Dialog Box

Enable a device by checking its checkbox. Disable a device by un-checking its
checkbox.
Galaxy uses enabled devices as:
•

•
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MIDI sources for auditioning
patches. If Play>Echo Keyboard is
checked, Galaxy sends data from any
enabled input device through to a
selected destination device. This
allows you to use a MIDI keyboard to
audition sounds on a MIDI sound
module. For more information, see
Playing Your MIDI Controller
(pg. 61).
MIDI sources for recording
sequences. For more information, see
Playing Sequences (pg. 62).
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•

•

Remote control devices for patch
selection. For more information, see
Remote Control (pg. 113).
MIDI sources for entering patch data
into an Editor Module (if you own
Galaxy Plus Editors).

STUDIO PATCHES USERS: Any Virtual
Controllers you create with Opcode’s Studio
Patches Editor application (included with
the Studio 4 and Studio 5LX) also appear
in this list.

Remote Control
Choose this command to open the
Remote Control dialog box.

Remote control is very useful when you’re
away from your Macintosh and want to
step through Library patches using your
MIDI keyboard. If you check the Load/
Send>Send on Select option, Galaxy
automatically sends patches to your synthesizer as you step through them.
To assign a MIDI event that causes
Galaxy to step forward through patches:
a Make sure the device you want to use
as a Remote Control is enabled in the
Enable Input Devices dialog box as
discussed in Enable Input Devices
(pg. 112).

b Click the Select next patch field.
c Play the MIDI event you want to use
as a remote control.
You can use any MIDI event such as an
Opcode footswitch, a particular MIDI
note, a control change, a program
change event, etc. The event then
appears in the selected field.

Figure 16.5: Remote Control Dialog Box

Use this dialog box to:
•
•

assign a MIDI event to step backward
through Galaxy patches.
assign a MIDI event to step forward
through Galaxy patches.
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To program a MIDI event that selects the
previous patch, perform the same steps in
the “Select previous patch” field.
To clear MIDI events, select the field and
type the Delete, Backspace, or Clear key.

OMS Studio Setup
Choose this command to open (or switch
to) the OMS Setup application. This
opens your current Studio Setup
document.
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OMS MIDI Setup
Use this command to open the OMS
MIDI Setup dialog box.

A
B

C
D

E

Figure 16.6: OMS MIDI Setup Dialog Box

As you can see in Figure 16.6, the OMS
MIDI Setup dialog box contains numerous elements. Specifically:
A

External ports to use
Check the box next to each Macintosh port you wish to use for MIDI
communication. If you choose to use
the same port for MIDI communications that your printer is connected
to, you will be unable to use the Print
command in Galaxy. You may, however, disable the port for printing and
then re-enable it when finished.
B Run MIDI in background
Checked: Enable this option if you
want OMS to share data between
compatible applications. When this
option is checked, OMS controls the
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selected serial ports as long as any
OMS-compatible application is open
(whether or not that application is
active).
ADVANTAGE: OMS 2.0-compatible
applications can communicate with
each other. For example, Galaxy can
control Vision’s Transport Controls as
discussed in OMS Transport
(pg. 127), or it can send MIDI data
directly to Vision as discussed in Send
MIDI To (pg. 120).
Un-checked: Disable this option if
you want OMS to relinquish control
of the serial ports when an OMS-compatible application is not active.
ADVANTAGE: Switching to a
non-OMS applications frees your serial
ports for use by that application. For
example, you could switch to a word
processor and print lyrics, or you could
switch to a telecommunication program and use your modem.
C New Easy Setup button
Click this button to create a new OMS
“Easy Setup” document. OMS guides
you through the process with a series
of dialog boxes. For more information
about Easy Setup documents, see
your OMS manual.
NOTE: OMS Easy Setup documents do
not contain information about the specific devices in your studio. Instead,
you should create a Custom Studio
Setup document for use with Galaxy.
D Edit Custom Setup button
Click this button to launch the OMS
Setup application and open your current Studio Setup document. Use
Custom Setups to tell OMS about
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each device in your studio. For more
information about Custom Studio
Setup documents, see your OMS
manual.
E Error Log button
Click this button to open the Serial
Port Errors dialog box, which contains a list of recent serial port errors
and their causes.
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NOTE: If you’re using an external MIDI
controller, make sure it’s enabled in the
Enable Input Devices dialog box as discussed in Enable Input Devices (pg. 112).
When you choose Record Sequence,
the following message appears:

Figure 17.2: Recording Instruction Message
Figure 17.1: Play Menu

The Play menu controls Galaxy’s numerous patch auditioning features. This
chapter discusses each command in the
Play menu. For a tutorial on using many
of these commands, please see
Chapter 10: Auditioning Patches.

Record Sequence
Choose this command to record a
sequence into Galaxy. A Galaxy sequence
is useful for listening to different patches
in a musical context. You can record a
sequence using either an external MIDI
controller or Galaxy’s MouseKeys.
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Play something on your MIDI controller
or on the MouseKeys. Stop recording by
clicking the mouse button in the message
window or by typing Return.
You can play the sequence using the Play
Sequence command, loop it with the
Loop Sequence command, and stop it
with the Stop Sequence command. For
more information, see Playing Sequences
(pg. 62).

Open MIDI File
Choose this command to open a standard
Macintosh Open dialog box. Use this
dialog box to locate and open single track
(format 0) Standard MIDI Files. You can
use a standard MIDI File as Galaxy’s audi-
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tioning sequence. You can play the MIDI
File sequence using the Play Sequence
command, loop it with the Loop
Sequence command, and stop it with the
Stop Sequence command. For more
information, see Playing Sequences
(pg. 62).

Stop Sequence

Galaxy keeps track of only one sequence.
If you open a MIDI File and play it, it will
replace the current recorded sequence or
MIDI File.

Check this option to automatically play
the Galaxy sequence every time you
select a patch. Make sure you also select
Send on Select in the Load/Send menu
for Play on Select to work. When you
select a patch, Galaxy will send the patch
to the device and the sequence will play.

NOTE: If your MIDI File plays on multiple
MIDI channels, you’ll probably want to
enable the Multi control in the MouseKeys
Window. Otherwise, all of the notes in the
sequence will play on the channel selected
in MouseKeys.

Play Sequence
Choose this command to play back the
sequence you recorded or the MIDI File
you opened. The sequence plays as you
continue to work in Galaxy. To set the
playback device and channel(s), see
Channel/Device Selection Controls
(pg. 57).
This command is disabled until you either
record a sequence or open a MIDI file.
You can stop playback at any time by
choosing Stop Sequence.

Choose this command to stop playback of
the Galaxy sequence.

Play on Select

Keyboard Thru
Check this option to have Galaxy send the
MIDI information from your MIDI controller back out to the device and channel
chosen in the MouseKeys Window. If
you’re using a rack-mount or expandertype synthesizer, this is a convenient way
to play and listen to patches you select.

All Notes Off (Panic)
Choose this command to silence stuck
notes.

Loop Sequence
Check this option to loop the Galaxy
sequence. Looping stops when you
uncheck Loop Sequence, or when you
choose Stop Sequence.
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Use Omni Mode for Multi-Ch. Play
If you are playing through more than one
MIDI channel, Galaxy offers you two possible strategies. You can either:
•
•

send every MIDI event on every
selected channel, or...
put the selected channels in Omni
mode, and send the data to the
lowest-numbered channel.

To use Omni mode, select Omni Mode
for Multichannel Play.
NOTE: Omni mode may not work with certain MIDI devices. You can communicate
with all devices without using Omni mode,
but any continuous controller information
(such as aftertouch, pitch bend, or modulation) will be significantly slower.
Omni mode is not used when the Multi
option is enabled in the MouseKeys Window. This is because Multi mode cannot
work if any device is set to Omni mode.

NOTE: OMS 2.0-compatible applications
that allow virtual destinations can record
this type of data in real-time. If you’re using
an OMS 2.0-compatible application, use
the techniques discussed in Send MIDI To
(pg. 120).
When you choose Capture To MIDI
File, all the above MIDI events are “captured” and saved temporarily. The
command then changes to Save MIDI
File. Capturing ends when you choose
Save MIDI File, and the captured information is saved permanently to a
Standard Format 0 MIDI File at a tempo
of 120 bpm.
MIDI Files are useful if, for instance,
you're working with a MIDI sequencer,
and you have a sequence that requires
several different patches at several different points in the sequence. To use the
Capture To MIDI File command:
a Choose Play>Capture To MIDI
File.

b Perform the operations you want to

Capture To MIDI File
This command allows you to save to disk
all MIDI information sent out by Galaxy.
This information can include:
•
•
•
•
•

patches
parameter changes
notes played on the MouseKeys
MIDI data echoed from your master
controller
playback of the sequence recorded
into Galaxy
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capture.
For instance, you can use the Load/
Send menu or Bundle menu to send the
patches you want to capture. Or you can
edit parameters in an Edit Window, play
sequences and MouseKeys, or echo the
keyboard.

c When you finish capturing events,
choose Play>Save MIDI File.
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d Specify a file name and click either
the Save button or the Save and
Clear button.
Use the Save button if you want to save
and continue capturing, appending
more data onto what you already captured. Use Save and Clear if you want to
save, but don’t intend to continue
capturing.

e In a MIDI sequencer, open the
resulting MIDI File and put its system
exclusive bulk dump messages into
the desired sequence location.

f Play the sequence.
Any patch transfers, edits, or notes captured in Galaxy are sent when the
sequence plays.

Of course, to use captured patch dumps
and parameter changes, your sequencer
must be capable of reading and playing
back system exclusive messages in Standard MIDI Files. Check your sequencer’s
documentation and make sure it is capable of doing this.
IMPORTANT: While capturing is enabled,
you should be careful about what operations
you perform. In particular, Get Patch and
Get Bank for many devices causes Galaxy
to transmit a patch request message. Since
you ordinarily would not want to capture
such a message, you shouldn't use these
commands while capturing is enabled. You
may also want to inhibit the capturing of
events like notes and controller changes. To
do this, check Only Capture Dumps &
Param Chgs. When this option is checked,
any notes or controller messages generated
by Galaxy are not captured.
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Clear Capture
Use this command when you don’t like
what you have captured so far and want to
start over. It erases everything captured
so far, and disables capturing. To begin
capturing again, choose Capture to
MIDI File.

Only Capture Dumps & Param
Chgs
When you check this option, Galaxy captures only patch dumps and parameter
change messages. If this option is not
checked, then everything sent out by
Galaxy is captured. This includes all playing by sequences, an echoed keyboard,
MouseKeys, or the Mac Keyboard.

Send MIDI To
The Send MIDI To submenu lists the
names of any open OMS 2.0-compatible
applications that are capable of receiving
MIDI data. These are called Virtual
Destinations.

Figure 17.3: Typical Send MIDI To Submenu

You can send MIDI data directly to any
number of Virtual Destinations by checking them in the submenu. You can also
select “No One,” which prevents Galaxy
from sending MIDI data to any Virtual
Destinations.
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NOTE: If there are no open Virtual Destinations, the Send MIDI To submenu
contains only one item: “No One.”
This feature is particularly useful for
recording real-time patch edits into a
sequencer (if you own Galaxy Plus
Editors). You can also use it to send entire
patch dumps to a sequencer.

f Open the desired Patch Edit Window
and make changes as Vision plays
your sequence.
You’ll hear all your changes in real-time
as Vision records them.
IMPORTANT: Vision records the data
using the Thru Instrument.

g Switch back to Vision and click the
Stop button.

IMPORTANT: In order to use this feature,
MIDI must run in the background. To do
this, choose Setups>OMS MIDI Setup to
open the OMS MIDI Setup dialog box, then
check the Run MIDI in background
option.
Sequencing Real-Time Patch Edits

h Play your sequence.
Vision plays the sequence including all
the patch edits you just made in Galaxy.

NOTE: Not all synthesizers are capable of
receiving system exclusive data while playing notes. See your device’s MIDI
specifications to determine it’s capabilities.

This example discusses how to record
real-time patch edits into Vision using
Galaxy Plus Editors.
a Choose Setups>OMS MIDI Setup
to make sure the Run MIDI in
background option is checked.

b Launch Vision and record-enable an
empty track.

c Click Vision’s Record button to start
recording.
You might want to set a countoff so you
have enough time to switch to Galaxy
Plus Editors.

d Switch to Galaxy Plus Editors.
e Select Setups>Send MIDI
To>Vision.
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•

•

Figure 18.1: Factory Menu

The Factory menu is available only if a
Bank or a Library is the active window.
Use it to access Galaxy’s Patch Factory™
algorithms.
Patch Factory is a special Opcode feature
that allows you to create new patches
through various controlled random techniques. With Patch Factory, you can:
•

•

Select a random grouping of patches
from a Library and paste them into a
Bank or Library (Library Sampler
algorithm).
Create patches based on the “shuffled” parameters of all the patches in
a Bank (Shuffler algorithm).

Create patches based on a gradual
transition from one patch to another
(Shade Two algorithm).
Create patches from random parameter variation based on the limits
imposed by two user-selected patches
(Constrained Random algorithm).

All four Patch Factory algorithms require
some form of “inspiration” Bank or
Library to use as a starting point. This is
explained in more detail when each Patch
Factory algorithm is discussed.
In general, to use Patch Factory:
a Make your “inspiration” Bank or
Library active.

b Choose one of the four algorithms
from the Factory menu.
Shade Two and Constrained Random
algorithms require that two patches be
selected as sources for the new patch.
See Shade Two (pg. 125) and Constrained Random (pg. 125) for specific
instructions.

c Decide whether you want to create a
full Bank of patches or a Library
containing any number of patches.

d Play your new sounds.
Randomly generated patches may not
always be musically useful, but represent a good method for generating new
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and surprising sounds. You can rename
the new patches, edit them (if you own
Galaxy Plus Editors), save them, or
throw them away.

The following sections discuss each Factory menu command (though not in the
same order as presented in the menu).

You can have some control over the
sound of the shuffled patches by planning
carefully when choosing your inspiration
Bank (or Library). For instance,
•

•

SHUFFLER
The Shuffler algorithm takes all the
parameters from the patches in your
inspiration Bank (or Library) and shuffles
them to create new patches—it’s as if you
threw all the parameters into a bag, shook
it, then removed the parameters one at a
time to create new patches.
For example, Galaxy might take the
Attack part of one patch’s envelope, combine it with the Decay of a different patch,
and apply the Sustain of a third. This
envelope could be modulated by the LFO
of another. This obviously produces a lot
of unusable patches, but it does provide
some surprisingly good ones. If you own
Galaxy Plus Editors, you can edit the
patches you create with Patch Factory.

If your inspiration Bank contains a
varied assortment of sounds, your
Shuffler created patches will produce
quite random results.
If your inspiration Bank contains very
similar sounds (all string patches for
instance), your Shuffler created
patches will produce patches that
mostly sound like strings.

To use Shuffler:
a Open the Bank or Library that you
wish to use as inspiration for the new,
random patches.

b Choose Factory>Shuffler.
A dialog box appears in which you specify whether you want the shuffled
patches put in a Bank or Library. You
can specify how many patches you want
in a Library.

Figure 18.2: Creating a Bank or Library with
Patch Factory

c Configure the dialog box, and click
the OK button to create a new Bank or
Library of shuffled patches.
The patches will all have random names.
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SHADE TWO

These patches sound
more like “AcGuitar”

The Shade Two algorithm looks at only
two inspiration patches to produce a new
collection of patches that gradually
progress from the sound of the first to the
sound of the second. The Shade Two algorithm is very useful when you want to
create a patch that has the same characteristics as two inspiration patches. For
example, if you have a guitar sound and
flute sound and you want to create a patch
somewhere between the two sounds, you
would use the Shade Two algorithm.
To use Shade Two:
a Open a Bank or Library that contains
the two patches you want to use as
inspiration.

b Click the name of the first patch and
shift-click the name of the second
patch.

c Choose Factory>Shade Two.
A dialog box appears in which you specify whether you want the shaded patches
put into a Bank or Library. You can specify how many patches you want in a
Library.

d Configure the dialog box, and click
the OK button to create a new Bank
or Library of shaded patches.
The patch names (as well as their sonic
characteristics) will gradually progress
from the first inspiration patch to the
second.
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These patches sound
more like “PuffyFlute”

Figure 18.3: Bank of Shade Two Patches

NOTE: This algorithm is not available for
some patch types.

CONSTRAINED RANDOM
The Constrained Random algorithm lets
you control, on a parameter by parameter
basis, the limits of random generation.
Like the Shade Two algorithm, it requires
that you select two inspiration patches.
Galaxy uses the parameter values of the
two inspiration patches as the upper and
lower limits of each parameter in the randomly generated patches. By careful
selection of your inspiration patches,
Galaxy can randomize some parameters
(those that are different in the inspiration
patches) while leaving others parameters
alone (those that are the same in the
inspiration patches).
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To create Constrained Random patches:
a Open a Bank or Library that contains
the two patches you want to use as
inspiration.

b Click the name of the first patch and
shift-click the name of the second
patch.

c Choose Factory>Constrained
Random.
A dialog box appears in which you specify whether you want the random
patches put into a Bank or Library. You
can specify how many patches you want
in a Library.

d Configure the dialog box, and click
the OK button to create a new Bank
or Library of constrained random
patches.

NOTE: This algorithm is not available for
some patch types.

LIBRARY SAMPLER
The Library Sampler algorithm is not a
patch generator—it's a random patch selector. It copies existing patches from a large
Library at random and pastes them into a
new, more manageable Bank or Library.
To use Library Sampler:
a Choose a Library to be the inspiration
Library, and click in its window to
make it active.

b Choose Factory>Library Sampler.
A dialog box appears in which you specify whether you want the patches put into
a Bank or Library. You can specify how
many patches you want in a Library.

c Click the dialog’s OK button to create
a new Bank or Library of randomly
selected patches.

DO AGAIN
Choose this command to create another
Bank or Library based on the most
recently selected Patch Factory algorithm. Galaxy remembers whether you
wanted a Bank or a Library (and how
many patches you wanted in that Library).
This makes it easy to quickly create many
Banks of patches based on the same
Patch Factory algorithm, or to create
random patches using other random
patches as inspiration.
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The MouseKeys Window opens automatically the first time you launch Galaxy.
Thereafter, the MouseKeys Window
opens at launch only if you left it open
when you last quit Galaxy. To learn to use
the MouseKeys Window, please see Playing the MouseKeys™ (pg. 55).

OMS Transport
Choose this command to open an OMS
Transport Window.
Play from beginning

Figure 19.1: Windows Menu

Pause

The Windows menu allows you to open
and close various Galaxy windows.

MouseKeys
Choose this command to open the
MouseKeys Window, which remains on
the screen for as long as it is checked in
the menu, or until you click in its close
box.

Stop

Figure 19.2: OMS Transport Window

Use the OMS Transport Window to control playback of any open
OMS 2.0-compatible applications. This
has numerous uses, for example:
•

Galaxy Manual

Play from current position

If you have a library of sounds and
you want to audition them in the context of the actual Vision sequence—
you can start, stop, and pause Vision
without leaving Galaxy.
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•

If you have Galaxy Plus Editors and
want to edit a sound in the context of
its Vision sequence—you can start,
stop, and pause Vision without leaving Galaxy.

In order to use the OMS Transport Window, you must make sure both OMS and
the application you wish to control are
configured properly. Specifically:
•

•

MIDI must run in the background.
To do this, choose Setups>OMS
MIDI Setup to open the OMS MIDI
Setup dialog box, then check the Run
MIDI in background option.
Remote Start must be enabled in the
application you wish to control.
To do this, select Options>Receive
Sync Mode>Remote Start to check
the Remote Start option.

NOTE: The counter may appear to work
somewhat erratically in the application
you’re controlling. This is because screen
redraws in non-active applications are
given low priority—rest assured that the
actual playback timing is accurate.

Vision
If you have purchased and installed
Vision, you may choose this command to
automatically launch it.

Save All
Choose this command to save the current
edits in any open Galaxy windows.

Enter Editor/Exit to Galaxy
The Enter Editor command is disabled
unless a bank window is active and a
patch is selected.
NOTE: This command is available only if
you have Galaxy Plus Editors.
When you choose this command an Edit
Window for the currently selected patch
opens, just as if you had pressed the
Bank’s Edit button. The name of the command then changes to Exit to Galaxy.
Choose this command to exit the Editor
Window and return to the bank window.
The Enter Editor/Exit to Galaxy command always selects the topmost Editor
or Librarian Window.

Next Window
Choose this command to send the active
window to the back and make the next
window active. If you choose this command repeatedly, you can “page” through
all the open Galaxy windows.

Close All
Choose this command to close all open
Galaxy windows.
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Open Windows List
The bottom of the Windows menu lists
all open Galaxy windows. The active
window is checked. To make any open
window active, simply check its name in
the Windows menu.
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IMPORTANT: In order to use Editor Modules, you must own Galaxy Plus Editors. If
you wish to upgrade from Galaxy to Galaxy
Plus Editors, please call Opcode’s Customer
Service department.

ABOUT EDITOR MODULES
Unlike Librarian Modules, which must be
installed in a special System file, Editor
Modules run from inside a folder called
Galaxy Editors, which Galaxy automatically creates in the same folder as the
Galaxy Plus Editors application.
IMPORTANT: Editor Modules cannot
function unless the corresponding Librarian Module is installed.

REMOVING EDITORS
The only way to remove Editors Modules
is to drag them out of the Galaxy Editors
folder and into the trash.
IMPORTANT: If you remove a Librarian
Module from Galaxy, any Editor Modules
corresponding to that Librarian Module
will no longer function, though they are still
stored in the Galaxy Editors folder.

PATCH EDITING EVOLUTION
“Patch” is a term from the early days of
electronic music when synthesizers consisted of individual electronic modules
linked together with “patch cords.” Synthesizer sounds became knows as
“Patches.”

INSTALLING EDITORS
Editor Module installation is discussed in
detail in Chapter 2: Installation & Setup.
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Today’s synthesizer “modules” are connected internally using advanced
computer software. Even though patch
cords are no longer used to create sound,
the terminology remains.
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Early synthesizers had a knob, switch or
slider for every adjustable parameter. You
could immediately accessible any parameter, which made sound-design relatively
simple. Unfortunately, all the knobs and
switches made synthesizers very
expensive.
To reduce costs and increase performance, synthesizer manufactures
removed all the knobs and switches and
put the parameters under software control. This resulted in synthesizers with
very few buttons and many pages of
parameter lists. It’s not uncommon on
today’s instruments to push a half-dozen
buttons in order to alter one parameter
setting. This editing method has produced more affordable synthesizers, but
has removed much of the experimentation, spontaneity, and sound design from
the musician.
Opcode Editor Modules are a solution to
complicated synthesizer programming.
An Opcode Editor can show many of the
synthesizer’s parameters on the Macintosh screen at once. You can “draw”
envelopes, change routings, and make
any adjustment with a simple click of the
mouse. All of your changes are transferred to your synthesizer in real time.

GENERIC EDITOR CONTROLS
This following sections describe editing
techniques common to all Opcode Editor
Modules.
In an Opcode Editor, most parameters are
of the following types:
•
•
•
•
•

numericals
toggles
guides
pop-up menus
envelopes

You can select different parameters by
clicking them or by stepping between
them with the ˜, ¿, ¯, or ˘ arrows.
NOTE: Not all editors support the use of the
arrows for stepping through parameters.
The following sections discuss the various
common parameter editing methods in
Opcode Editors.

In addition, since Opcode Editor Modules
install into Galaxy Plus Editors, you will
be able to save your creations into Banks
or Libraries. This means you can use a
single application for creating and storing
all of the patches for your synthesizers.
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b To increment a numerical value,

Numericals
Numericals are values that you can edit
on the Macintosh screen. You can usually
identify numericals by their bold type.
Opcode programs give you four ways to
edit the value of a numerical:
•
•
•
•

Method 1: Increment/Decrement
Method 2: Sliders
Method 3: Typing
Method 4: MIDI entry

position the cursor in the top half of
the numerical and click the mouse.
When the cursor is an up arrow, single
mouse clicks increment the numerical
value. Click and hold the mouse to
increase the numerical value rapidly.

c To decrement a numerical value,

These methods are discussed in the following sections.

position the cursor in the bottom half
of the numerical and click the mouse.

Method 1: Increment/Decrement

When the cursor is a down arrow, single
mouse clicks decrement the numerical
value. Click and hold the mouse to
decrease the numerical value rapidly.

You can increment/decrement the value
of any numerical using either the mouse
or your computer keyboard.

To use the computer keyboard:

To use the mouse:

a Type ] (closing bracket) to increase

a Position the cursor either just above
or just below an imaginary center line
running through the numerical.
The cursor will turn into either an upward
or downward pointing arrow depending
on its position relative to the center line.

the value of the currently selected
numerical.

b Type [ (opening bracket) to
decrease the value of the currently
selected numerical.

Up Arrow (Increase Value)
Center Line of Field
Down Arrow (Decrease Value)

Figure 20.1: Typical Numerical
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Method 2: Sliders

Method 4: MIDI Entry

Use the mouse as a “slider.” To change a
numerical in this way:

Some numericals contain MIDI note
values or some other type of MIDI data. A
simple way to edit these numericals is to
use your MIDI keyboard. To do so:

a Press and hold the mouse button on
the numerical.

b While still holding the mouse button,
drag the mouse in a vertical direction.
Pushing the mouse away from you
increases values.
Pulling the mouse toward you decreases
values.

NOTE: The cursor disappears while the
value is changing and reappears when you
release the mouse button.
Method 3: Typing
Some numericals allow you to type a
value. To do so,
a Click the numerical.
It highlights.

b Type a number.

a Select the numerical you wish to edit.
For example, the numerical might contains a MIDI note value (such as a range
numerical).

b Play your MIDI keyboard.
The numerical changes to the value sent
from your MIDI keyboard.
For example, if the numerical contains a
MIDI note value, it will change to the
note you played on your MIDI keyboard.

This technique works for all types of
MIDI data including velocities and MIDI
controller values.

Toggles
Toggles are shaded squares that turn
some parameter on or off.

You'll see three dots (“…”) after the
value you type. This means that the
value is pending.

c Press the Enter or Return keys.
The numerical changes to reflect the
new value. You will not be allowed to
enter invalid values.
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When a square is shaded, the toggle is on;
when a square is white, the toggle is off.
Simply click in a toggle to change its
state. When there are a number of toggles
next to each other, you can drag across
them to set all their states at once.
You can also use the bracket keys
([ or ]) to change the value of the
selected toggle.

Guides
Some Editors use a “Guide” as an additional method of editing parameters. The
guide is simply a big slider that you can
use to edit the selected parameter.

Envelopes
Some Editors contain miniature envelope
displays.

Figure 20.4: A Miniature Envelope

If your Editor Window contains a small
envelope display, you can usually click it
to open a large, editable graphic envelope.
You can then edit the envelope by dragging its corners with the mouse.

Figure 20.5: Typical Graphic Envelope
Figure 20.3: Guide Containing Scroll Bar

You can use the guide to make changes to
the selected parameter in several ways:
•
•

•

Click in the shaded area. The slider
thumb jumps to the place you clicked.
Click the + or - boxes on the ends of
the guide to make incremental
changes to the parameter’s value.
Drag the thumb inside the shaded
area (like a data entry slider on a real
synthesizer or a fader on a mixing
console).
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Of course, you don't have to use the
graphic envelope to edit the envelopes.
You can also alter envelopes using traditional numerical editing techniques as
discussed in Numericals (pg. 135).

Pop-Up Menus
Pop-up menus are used when a parameter
has many non-numeric values. Generally
(though not always), pop-up menus contain some kind of small triangle.
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Figure 20.6: Typical Pop-up Menu

Some pop-up menus have multiple levels.
This is necessary when there are too
many choices to fit on a single screen.
These pop-up menus have blocks that
allows you to select different groups of
parameters.

NOTE: Some numericals can only be
changed by pop-up menu. These do not have
a small triangle on their right edge. Clicking anywhere in the numerical opens the
pop-up menu.
To use a pop-up menu:
a Press and hold the mouse on the
small triangle.
A pop-up menu appears.

b While still holding the mouse button,
drag the cursor over the desired
value.

c Release the mouse when the desired
value is highlighted.
If you don’t want to make a new selection, simply drag the mouse out of the
pop-up menu before releasing the
button.

Figure 20.7: Typical Multi-Level Pop-Up Menu

To select parameters from a multi-level
pop-up menu:
a Open the pop-up menu as discussed
previously.

b While still holding the mouse button,
drag the cursor over the desired
group at the bottom of the pop-up
menu.
Selecting a group changes the pop-up
menu to display all values for that group.

c While still holding the mouse button,
and with the new group selected, drag
the cursor over the desired value and
release the mouse button.
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EDITOR AND GALAXY WINDOW
INTERACTION
Since you can have Editor Windows and
other Galaxy windows open at the same
time, there is some inter-relationship
between them. The following sections discuss those relationships.

Closing a Galaxy Window
Closing a Galaxy window causes all of the
Editor Windows containing patches from
that Galaxy window to close. If an Editor
Window contains an edit that you haven't
saved, you'll be asked if you want to save
changes, at which point you can save your
changes, discard your changes, or cancel
the command.

Renaming a Galaxy Window
When a Galaxy window is renamed (by
using the Save As command), Editor
Windows containing patches from that
Galaxy window will display the Galaxy
window's new name.

Renaming the Edited Patch
If you happen to use Galaxy to rename a
patch being edited, the new name will be
entered into the Bank or Library and the
current edit. This is the only case where a
change you make to a Bank or Library
affects a patch being edited.
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Pasting, Clearing, or Cutting the
Edited Patch
Any of these actions will bring up a message asking if you want to discard both
your current edit and its stored version.
If you click Cancel, things will be left as
they were. If you click Discard, the current Edit Window will close and your
paste, clear, or cut will be performed.

Loading into the Location of the
Edited Patch or into its Entire
Bank
This will bring up a message asking if you
want to discard both your current edit and
its stored version.
If you Cancel, things will be left as they
were. If you click Discard, the current
edit window will close and your load will
be performed.

Pasting Patches into a Library
When you paste a patch into a Library
while editing a patch in that Library, the
Patch menu gets adjusted to reflect the
addition of that patch. You may optiondrag the title bar of the patch being edited
and drag it to a Library or Bank as an
alternate copy and paste method.
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Cutting or Clearing Patches from
a Library
When you cut or clear a patch from a
Library while editing a patch in that
Library, the Patch menu gets adjusted to
reflect the removal of that patch.

Storing a Patch
When you store an edited patch, its new
name (if any) will be displayed in the
Galaxy window.

Selecting a Patch
When you select a new patch from the
Patch menu in an Editor Window, that
patch becomes selected in its Galaxy window. You won't notice this until you make
the Galaxy window active since selected
patches aren't visible in windows that
aren't active.
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This chapter describes menu commands
and options that appear whenever an
Editor Window is active, and which
behave the same for all Editors. It also
describes operations that do different
things depending on whether an Editor
Window is active or a Galaxy window is
active. If any special features apply to a
specific Editor Module, these will be discussed in a device-specific manual.
The Opcode Proteus Editor module is
used as an example, though the discussion applies to all Opcode Editors
Modules.

FILE MENU
Refer to Chapter 10 for a full description
of the File menu. Some File menu commands operate slightly differently when
Editor Windows are active and these are
outlined here:

Close
The Close command closes the topmost
Editor Window.
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Save and Save As
The Save and Save As commands store
your currently edited patch, then save the
Bank, Library or Bundle document containing the patch.

Print
The Print command prints the currently
edited patch.

EDIT MENU
When an Editor window is active, the Edit
menu is different from the Galaxy Edit
menu. Also, the Edit menu varies depending on the type of patch you’re editing.

Undo/Redo
Most editing commands are un-doable.
If you make a series of changes to a single
parameter, Undo will return you to the
original value of the parameter, before
you made your first change. For all other
editing commands, Undo will undo only
the last operation you performed.
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After you perform an Undo, the command in the menu changes to Redo.
Choosing this command will change
things back to the way they were before
you chose Undo.

Copy
You can copy and paste one or more
parameters, or any logical collection of
parameters.

If multiple items were copied, then the
order in which you selected them before
copying them is important. When you
copy multiple items, they are put on the
Clipboard in the order that you selected
them. If, for example, you selected Item 1,
then Item 2 when you copy them, the
Clipboard will contain Item 1 and Item 2,
in that order.

Whole groups of numericals can be
copied and pasted from one patch to
another, and to any other group of numericals of the same type. In some cases,
individual parameters within one of these
groups can be pasted to parameters
within some other group.

When you want to paste multiple items,
the order in which you select the destinations is also important. To continue our
example, suppose you select Item 2 then
Item 1, in that order. When you choose
Paste, the items on the Clipboard are
pasted to the destinations in the order
that the destinations were selected. So
Item 1 is pasted to Item 2, and Item 2 is
pasted to Item 1.

To copy a numerical or group of numericals, first select it by clicking it, then
choose Edit>Copy.

If you select a different number of destinations than the number of items on the
Clipboard, the smaller number are pasted.

To select more than one parameter for
copying, hold down the Shift key while
selecting them.

Paste Child Patch

Once you have selected the parameter(s)
to be copied, choose Edit>Copy.

Certain Editors allow the pasting of child
patches. For details, see the Editor
manual for your specific MIDI device.

Paste

Initialize

To paste one or more copied parameters
to a different location, select the destination parameter(s). Then choose
Edit>Paste.

This command replaces the current edit
with a copy of the Empty Patch. You will
be asked if you are sure you want to do
this, since the command is not un-doable.
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Compare/UnCompare
Compare allows you to temporarily
revert to the last stored version of your
current edit. When you choose this command, the last stored version is displayed
in the Editing Window and sent to your
synthesizer. To indicate that you are in
Compare mode, the small black dot in the
upper right corner of the window (next to
the ID) will blink.

Layer’s Editor Windows become disabled.
While this is not a problem, you should be
aware of the situation whenever you choose
Compare.

Edit Name
Use Edit Name to change the name of
the current edit. Patch names vary in
length depending on the type of patch you
are editing. If you attempt to enter more
letters or numbers than will fit in the
name, the Editor will beep.

Figure 21.1: Compare Dot Blinks

Show Numerical/Graphical Data
To return to your previous edit, choose
UnCompare. Your edited version of the
patch reappears in the Editing Window
and is sent to your synthesizer. The small
black dot stops blinking.
If you have not changed the patch since it
was last stored (indicated by a white
circle instead of a black dot), the Compare command is disabled.
NOTE: While you are in Compare mode, it
is possible to make changes to the patch, but
you won't be able to save these changes.
IMPORTANT: If you choose Compare
after adding new objects to a patch, you
may find yourself with an Editor Window
full of disabled numericals. For example, if
you are editing a layer that you’ve just
added to a Program, and choose Compare, the Layer you are editing no longer
exists. To reflect this, all numericals in the
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This option lets you determine whether
envelopes and other graphic objects are
shown as numericals, or as graphics.

LOAD/SEND MENU
The Load/Send menu works differently
when you have an Editor Window open.
Get Patch will fill both the current edit
window and its stored version with the
patch in the synth’s edit buffer. Similarly,
Get Bank fills both the current Edit
Window and the Bank associated with the
current Edit Window. Send Patch sends
the patch in the current Edit Window, not
its stored version.
If you choose Store Patch or Send Bank
while editing, the current edit will be
saved first. Then the patch will be stored
or the Bank sent.
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Read the Editor Manuals for your specific
MIDI device for further information.

PATCH MENU
“Patch menu” is a generic term for a
menu titled with the type of patch you’re
editing (for example, when you’re in the
Preset Editor, you’ll see a Preset menu).
The Patch menu allows you to store current edits, and to choose other patches to
edit. In the menu are the names of all the
patches in the Bank or Library containing
the edited patch. The patch you're currently editing has a check mark by it.

Selecting a Patch
When you select a patch from a Patch
menu, the patch is sent to your synthesizer and appears in the current Editor
Window.
The Patch menus are either Bank or
Library menus.

Bank Menus
The patches will have numbers next to
them, the way that they do in Bank Windows. Bank menus usually have several
columns of patches, unless there are too
many patches in a Bank (or their names
are too long) to see them all at once, in
which case they act like Library menus.

Library Menus
Library menus display 16 patches at a
time. The arrows visible after you pull the
menu down are for scrolling the menu.
Drag the cursor into one of these arrows.
The double arrows are “fast-forward” and
“rewind,” the single arrows are for slower
scrolling.
Figure 21.2: Patch Menu
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Selecting the Currently Checked
Patch
If you have edited a patch and want to
return to the original copy of the patch
(perhaps you have mangled a steel drum
sound into a close replica of a car door
slam), just select the currently checked
patch in the Patch menu. If you have
made any changes to the patch, you are
given three choices:

Storing to a Different Location
Sometimes you may want to store your
current edit without replacing the original
version of the patch. There are two ways
to do this:
To store a patch in a Bank to a different
location in the same Bank:
a Hold down the Command key, then
choose, from the Patch menu, the
location into which you want to store
your patch.

To store a patch into a different Bank or
Library, or with a new name into the same
Library:
Figure 21.3: Revert to Stored Dialog Box

Revert will replace your edited version
with the stored version. Discard cancels
the command. Resend resends your
edited patch to the synthesizer without
reverting to the stored version.

a Drag the Editor Window so that the
bank or library window you want to
store into is visible.

b Option-click the name of the patch, or
anywhere in the title area of the
window.
A gray rectangle appears.

Store Current Edit
Store Current Edit will store your edited
version of the patch in its Bank or Library.
You can also press Command-Spacebar.
NOTE: This command does not save the
Bank, Library or Bundle document containing the edited patch; to do so, choose
File>Save or File>Save As.
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c Drag the gray rectangle into the
window you want to store into.
If storing into a Bank, drag the gray rectangle over the location in the Bank you
want to store the patch in.

d Release the mouse button.
The current edit is stored in the Bank or
Library you dragged it into.
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Note that the Patch menu will now display
the patches in the window you dragged
the patch into. If you want to edit patches
from the window the dragged patch came
from, you'll have to choose a patch from
that window, then click the Edit button to
open a new Editor Window.

PLAY MENU
When an Editor Window is open, The
Play menu contains an additional command, discussed below.

Play on Parameter Change
If you are using a recorded sequence or
MIDI file and you want to hear the
sequence played every time you change
the sound, check Play on Parameter
Change. Every time you change a value
in the Editor, the sequence will play.

WINDOWS MENU
The Windows menu is the same in
Editors.
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Attack
V. Fast Attack
Fast Attack
Medium Attack
Slow Attack
V. Slow Attack
Brass
Brass Section
Bugle
Cornet
Flugelhorn
Horn
Sousaphone
Trombone
Trumpet
Tuba
Synth Brass
Brightness
Very Bright
Bright
Avg. Brightness
Dark
Very Dark
Drum Kit
Snare
Toms
Kick Drum
Cymbal - Splash
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Cymbal - Crash
Cymbal - Ride
Cymbal - Sizzle
Cymbal - China
HiHat - Open
HiHat - Loose
HiHat - Closed
HiHat - Pedal
Sidestick
Rimshot
Effects
Chorus
Delay
Echo
Filter Sweep
Flange
Gated
Pan
Pitch Shift
Pitch Sweep
Reverb
Ensemble
Solo
Small Ensemble
Medium Ensemble
Large Ensemble
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Feel
Happy
Euphoric
Melancholy
Sad
Depressed
Angry
Anxious
Confused
Funny
Tense
Relaxed
Scary
Sexy
FX Amount
Small Effects
Average Effects
Large Effects
General MIDI
Acoustic Grand Piano
Bright Acoustic Piano
Electric Grand Piano
Honky-Tonk Piano
Electric Piano 1
Electric Piano 2
Harpsichord
Clavinet
Celesta
Glockenspiel
Music Box
Vibes
Marimba
Xylophone
Tubular Bells
Dulcimer
Drawbar Organ
Percussive Organ
Rock Organ
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Church Organ
Reed Organ
Accordion
Harmonica
Tango Accordion
Acoustic Guitar (nylon)
Acoustic Guitar (steel)
Electric Guitar (jazz)
Electric Guitar (clean)
Electric Guitar (mutes)
Overdriven Guitar
Distortion Guitar
Guitar Harmonics
Acoustic Bass
Electric Bass (finger)
Electric Bass (pick)
Fretless Bass
Slap Bass 1
Slap Bass 2
Synth Bass 1
Synth Bass 2
Violin
Viola
Cello
Contrabass
Tremolo Strings
Pizzicato Strings
Orchestral Harp
Timpani
String Ensemble 1
String Ensemble 2
SynthStrings 1
SynthStrings 2
Choir Aahs
Voice Oohs
Synth Voice
Orchestra Hit
Trumpet
Trombone
Tuba
Muted Trumpet
French Horn
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BrasSect
SynthBrass 1
SynthBrass 2
Soprano Sax
Alto Sax
Tenor Sax
Baritone Sax
Oboe
English Horn
Bassoon
Clarinet
Piccolo
Flute
Recorder
Pan Flute
Blown Bottle
Shakuhachi
Whistle
Ocarina
Lead 1 (square)
Lead 2 (sawtooth)
Lead 3 (calliope)
Lead 4 (chiff)
Lead 5 (charang)
Lead 6 (voice)
Lead 7 (fifths)
Lead 8 (bass+lead)
Pad 1 (new age)
Pad 2 (warm)
Pad 3 (polysynth)
Pad 4 (choir)
Pad 5 (bowed)
Pad 6 (metallic)
Pad 7 (halo)
Pad 8 (sweep)
FX 1 (rain)
FX 2 (soundtrack)
FX 3 (crystal)
FX 4 (atmosphere)
FX 5 (brightness)
FX 6 (goblins)
FX 7 (echoes)
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FX 8 (sci-fi)
Sitar
Banjo
Shamisen
Koto
Kalimba
Bagpipe
Fiddle
Shanai
Tinkle Bell
Agogo
Steel Drums
Woodblock
Taiko Drum
Melodic Tom
Synth Drum
Reverse Cymbal
Guitar Fret Noise
Breath Noise
Seashore
Bird Tweet
Telephone Ring
Helicopter
Applause
Gunshot
Guitars
Classical Guitar
Folk Guitar
Electric Guitar
Steel Guitar
Pedal Steel Guitar
12 String Guitar
Electric Bass
Fretless Bass
Upright Bass
Banjo
Harp
Mandolin
Synth Bass
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Keyboard
Acoustic Piano
Electric Piano
Organ
Harpsichord
Clavichord
Clavinet
Accordion
Rhodes
Wurlitzer
Hammond Organ
Pipe Organ
Vox Organ
MIDI Controls
Aftertouch
MIDI Volume
Mod Wheel
Pitch Bend
Sus Pedal
Velocity
Musical Style
Pop
Rock
Jazz
Techno
Latin
R&B
Orchestral
Blues
New Age
Film
Ethnic
Country/Folk
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Part
Soprano
MezzoSoprano
Alto
Tenor
Baritone
Bass Part
Contrabass
Contra alto
Lead
Comp
Pad
Percussion
Agogo
Bells
Belltree
Birembau
Bongo
Cabasa
Castanets
Celesta
Chimes
Churchbell
Clap
Claves
Conga
Cowbell
Crotales
FingerCyms
FingerSnap
Flexitone
Glasses
Glockenspiel
Gong
Gourd
Guiro
Handbell
Handclap
Kalimba
Kinto
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Logdrum
Maracas
Marimba
Scraper
Shaker
Steel Drums
Talking Drum
Tambourine
Temple Blocks
Timbale
Timpani
Triangle
Tubular Bell
Tumba
Tympani
Vibraphone
Vibraslap
Waterphone
Whip
Windchimes
Wineglass
Woodblock
Xylophone
Synth Percussion
Performance
Arpeggio
Backwards
Bowed
Brushed
Chord
Fall
Flam
Flutter
Gliss:Up
Gliss:Down
Growl
Harmonics
Legato
Muted
Pick
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Pizzicato
Portamento
Random
Repeated
Riff
Rise
Roll
Scrape
Slap
Stabs
Staccato
Struck
Swell
Tremolo
Vibrato
Rating
Great
Good
Average
Poor
Terrible
Realism
Very Realistic
Realistic
Avg. Realism
Synthetic
Very Synthetic
Release
V. Fast Release
Fast Release
Medium Release
Slow Release
V. Slow Release
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Sound Effects
Airplane
Buzzer
Cat
Computer
Dog
Door Slam
Explosion
Glass Break
Gunshot
Helicopter
Machine Gun
Motor
Motorcycle
Music Box
Ocean
Rain
Space/Alien
Splash
Thunder
Tire Screech
Environment
Wind
Split/Layer
Keyboard Split
Velocity Split
Layer
Crossfade
Strings
Violin
Viola
Cello
Double Bass
String Section
Orchestra
Synth Strings
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Sustain
V. Short Sustain
Short Sustain
Medium Sustain
Long Sustain
V. Long Sustain
Synth
Analog Synth
Digital Synth
Sampled Synth
Hybrid Synth
Tone Color
Airy
Aggressive
Belltone
Brassy
Breathy
Brittle
Buzzy
Clean
Crystalline
Dissonant
Distant
Distorted
Edge
Ethereal
Evolving
Glasslike
Gnarly
Hollow
Lush
Metallic
Microtonal
Muffled
Nasal
Noisy
Percussive
Reedy
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Resonant
Thick
Thin
Toylike
Warm
Woody
Vocals
Male
Female
Male/Female
Synth Vocals
Humming
Consonants
"ae"
"ah"
"ee"
"eh"
"ie"
"ih"
"oh”
"oo"
"uh"

World
Bagpipes
Balalaika
Bandoura
Cittern
Domra
Dulcimer
Gamba
Koto
Lute
Lyre
Ocarina
Panpipes
Samisen
Shakuhachi
Sitar
Ukelele
Tambura
Zither

Woodwinds
Flute
Saxophone
Oboe
English Horn
Clarinet
Bassoon
Harmonica
Recorder
Piccolo
Mixed Winds
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APPENDIX B: Using Galaxy with the
OMS Name Manager

The OMS Name Manager can subscribe
to any Bundle saved by Galaxy 2.0. This
creates the following benefits:
•

•

Compatible applications display
patches by name rather than number.
The patch names are “read” from
your Galaxy Bundles—if you modify a
Galaxy Bundle, the changes automatically appear in the compatible
application.
Advantage: A compatible sequencer
always knows what patches are in
your synthesizers and displays those
patches by name.
Compatible applications let you view
patches by category. You can define
patch categories using Galaxy’s Keywords dialog box, discussed in
Chapter 11: Cataloging Patches.
Advantage: A compatible sequencer
lets you display only those patches
that you’ve categorized a certain way.
For example, if you want a woodwind
sound, a compatible sequencer can
show you only those sounds categorized as Woodwinds in Galaxy.
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The following example illustrates both of
these capabilities using Vision as an
example.

SUBSCRIBING TO BUNDLES
NOTE: This example briefly shows how
Vision uses the OMS Name Manager. Any
fully OMS 2.0-compatible application will
have similar features, though its user interface might be different. See your OMScompatible application manual for full
details.
Before Vision can display patches alphabetized by name, you must subscribe to
the desired Bundles using OMS Name
Manager. To do so:
a In Vision, choose Windows>Names.
The OMS Name Manager window
opens.
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b Subscribe to Galaxy Bundles for each
device in your studio.
See your Vision manual for details.

SELECTING PATCHES BY
GROUP
If you have large banks of patches, it can
be quite frustrating to find patches that
have a particular sound, even when you
can see their names.
To view patches by category (as defined
by Galaxy’s Keyword dialog box):
a Double-click the little trumpet icon in
Vision.

SELECTING PATCHES BY NAME
Once you’ve subscribed to Galaxy Bundles, Vision can display patches
alphabetized by name rather than by
number.

The Modal Browser opens.

b Use the Modal Browser to view only
patches that match Keyword criteria
established in the Galaxy application.
For example, the following figure shows
the patches in a Matrix-1000 Bundle that
have been categorized as “Brass.”
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c Select the desired brass patch and
click the OK button.

This is much easier than hunting through
a list of 100 patch names for ones that
might be brass patches.
IMPORTANT: See your OMS-compatible
application manuals for detailed descriptions of the OMS Name Manager.

Galaxy Manual

159

PART 6: Appendix

160

Opcode Systems, Inc.

APPENDIX C: Glossary

Attached Patch: Most modern synthesizers have a patch hierarchy such that one
type of patch references another type of
patch (for instance a “Program” patch
may reference an “Effect” patch). These
types of patches are called Attached
patches since they have other patch types
“attached” to them. See Child Patch and
Parent Patch.

Bank: Patches of the same type are
stored together in banks. A Galaxy bank
contains the same number of patches as
the corresponding bank in your MIDI
device.

Basic MIDI Channel: Some devices
(usually older) do not have a separate
channel on which system-exclusive messages can be communicated so they
designate one of the 16 (or 32) MIDI
channels to send and receive sys-ex data.
This is the “basic” MIDI channel.
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Bundle: Most MIDI devices store more
than one type of patch and, therefore, contain more than one bank. Galaxy allows
you to store all the banks for a particular
MIDI device together in a single bundle.
In addition, bundles can contain banks
from numerous devices.

Child Patch: When a patch is referenced
by another patch, the referenced patch is
called a Child patch. If, for example, a
“Program” patch references a particular
“Effect” patch, then the Effect patch is
called a Child patch. See Attached Patch
and Parent Patch.

Device: See MIDI Device.

Device ID: This is a standard term for a
device's setting that uniquely identifies
the device. In the same way that note
information is conveyed on a specific
MIDI channel, patch (system-exclusive)
information usually contains a device ID
specifying the device to which the patch
data is directed. OMS Studio Setup documents and device front panels usually
contain device IDs. When these IDs are
set identically, patch data can be trans-
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ferred from the device to Galaxy and back
to the device. On some devices (usually
older ones), there is a “basic” MIDI channel that also functions as a device ID.
Instead of “device ID,” some manufacturers may use the terms “MIDI ID,” “unit
ID,” “unit number,” “device number,”
“system-exclusive ID....”
Library: MIDI devices can contain only a
fixed number of patches in a bank. Galaxy
allows you to create files that store as
many patches as memory allows. These
files are called libraries.

MIDI Device: A term referring to MIDI
instruments, effects units, and drum
machines.

Name List: A set of patch names that can
be recalled by the 128 MIDI program
change messages, or a set of note names.
Many devices have multiple patch name
lists, which correspond to multiple working modes of the device.

OMS: OMS is an acronym for the Open
Music System. OMS is a Macintosh
system extension developed by Opcode
that Galaxy uses to communicate with all
the MIDI hardware in your studio. OMS
provides a central location (called the
Studio Setup document) for defining and
storing a detailed description of the
devices in your MIDI studio and the
patches within those devices.

162

OMS Name Manager: Galaxy Bundles
automatically publish their names to the
OMS Name Manager. OMS 2.0 compatible applications use the OMS Name
Manager to view patch names stored in
Galaxy Bundles. This lets you select
patches by name in an OMS 2.0 compatible application.

Parent Patch: When a patch references
another patch, it’s called a Parent Patch.
If, for example, a “Program” patch references a particular “Effect” patch, then the
Program patch is called a Parent patch.
See Attached Patch and Child Patch.

Patch: A “patch” in this manual refers to a
block of data as represented internally in
a MIDI device. Patches can determine
more than the actual sound. Some manufacturers may use the terms “program,”
“voice,” “preset,” “tone,” “waveform,”
“combi,” “multi,” “performance,” “split,”
“system setup,” “program change table,”
“tuning table....”

Sub-Instrument: Opcode's term for one
of the “players” within a multitimbral synthesizer that enable the synth to
simultaneously play several different
sounds on different MIDI channels. Some
manufacturers may use the terms “part,”
“tone generator,” “instrument,”
“section....”
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System Exclusive Message: A MIDI
message containing patch information
that is specific to a single kind of device.
System-exclusive messages are usually
communicated between MIDI devices
and computers.

Virtual Destination: Any open OMS 2.0compatible application that can receive
MIDI data from a different application.
For example, Vision can record MIDI
data sent from Galaxy—therefore Vision
is a Virtual Destination in they eyes of
Galaxy.
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INDEX
A
Add Device command 31, 103
All Notes Off command 118
Attached Patches
copying 50
Cross-Referencing 100
definition 19
w/stand-alone Banks 39
Auditioning Patches
w/computer keyboard 62
w/MIDI controller 61
w/MouseKeys 55
w/sequence 62
Auto option 58
Auto-rename uses preference 111

B
Bank List
viewing 28
Bank Window
anatomy 36
anatomy of stand-alone Bank 40
naming Patches 38
Patch list 36
selecting patches 37
sending individual Patches 38
sub-instrument control 37
Banks
bundled 35
copying Patches 49
creating stand-alone Banks 39
definition 18
exporting to other applications 92
opening bundled Banks 35
stand-alone 39
viewing Patches 36
Banks in Device command 29, 103
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Bundle Menu 101
Add Device 31, 103
Banks in Device 29, 103
Delete Template 33, 104
Get All Banks from (Device) 30, 102
Get All Banks in Bundle 31, 102
Remove Device 104
Save As Template 32, 104
Send All Banks in Bundle 32, 103
Send All Banks to (Device) 31, 102
View By Icon 28, 104
View By Name 28, 104
Bundle Templates 32, 86
Bundle Window
anatomy 26
Bank List 28
Device ID 28
multiple MIDI devices 31
OMS Device Selection 27
opening Banks 35
rearranging device order 32
selecting Banks to include 29
Bundles
Bundle Window 26
bundled Banks 35
containing multiple MIDI devices 31
creating 25
creating templates 32
definition 18
deleting templates 33
filling 30
opening Banks 35
saving 30
selecting Banks to include 29
sending data to MIDI device 31
using 35
using templates 33

C
Capture To MIDI File command 119
Categories
custom 68
deleting 68
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Index

Child Patch Info command 99
Child Patches
copying 50
Cross-Referencing w/Parents 100
definition 19
viewing information 51
w/stand-alone Banks 39
Clear Capture command 120
Clear command 96
Close All command 128
Close command 88
w/Editor active 141
Comments
attaching 69
definition 65
finding 73
Compare command 143
Constrained Random command 125
Copy
between Banks & Libraries 49
Parent/Child Patches 50
Patch Bank to Library 44
Patches to Library 43
Copy command 96
w/Editor active 142
Copy Names command 52, 98
Cross Reference Bank command 100
Cross Reference Window 100
Custom Menu
PatchTalk and Programming Mode 110
Cut command 95

D
Delete Child Patches command 98
Delete Duplicate Patches command 98
Delete Template command 33, 104
Devices
configuring 29
selecting in Bundle Window 27
setting Device ID 28
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Disks
contents 10
locking/unlocking 9
Do Again command 126
Documentation
conventions 4
Technical Publications 7
using 3

E
Echo Keyboard command 61, 118
Edit Menu 95
Child Patch Info 99
Clear 96
Compare 143
Copy 96
Copy (Editor active) 142
Copy Names 52, 98
Cross Reference Bank 100
Cut 95
Delete Child Patches 98
Delete Duplicate Patches 98
Edit Name 143
Enter Names 38, 96
Graphical Data 143
Initialize 142
Paste 96
Paste (Editor active) 142
Paste Child Patch (Editor active) 142
Patch Info 65, 99
Select All 96
Set Empty Patch 99
Show Numerical 143
Testing Sounds 62, 97
UnCompare 143
Undo 95
Undo (Editor active) 141
Edit Name command 143
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Index

Editing Techniques
Envelopes 137
Guides 137
Numericals 135
Pop-up menus 137
Toggles 136
Editor Modules
drag and drop installation 12
editing. See "Editing Techniques"
installing automatically 11
interaction w/Librarians 139
location on hard disk 133
overview 11
removing 133
Enable Input Devices command 61, 112
Enable Input Devices dialog box 112
Enter Editor command 128
Enter Names command 38, 96
Envelope editing 137
Exit to Galaxy command 128
Export to Clipboard command 90
Exporting
Banks 92
basics 90
Patches 91
potential problems 93
viewing data 93

F
Factory Menu 123
Constrained Random 125
Do Again 126
Library Sampler 126
Shade Two 125
Shuffler 124
File Menu 85
Close 88
Close (Editor active) 141
Export to Clipboard 90
Find 71, 90
Find Again 72, 90
New Bank 39, 86
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New Bundle 25, 85
New Library 41, 87
Open 87
Print 90
Print (Editor active) 141
Print command 52
Quit 94
Save 30, 89
Save (Editor active) 141
Save And Make Current 89
Save As 89
Find
comments 73
Fewer Choices option 90
Keywords 75
limiting searches 80
More Choices option 90
Patch Names 73
Patch Type 80
Patches w/General Find 71
Patches w/Specific Find 73
saving specs as a Macro 79
Find Again command 72, 90
Find command 71, 90

G
Galaxy Basics
auditioning Patches 55
cataloging Patches 65
contacting Opcode 6
creating bundles 25
disks 9
documentation 3
finding Patches 71
hardware connections 14
installing Galaxy 10
installing OMS 9
intro 3
Libraries 41
on-line help 23
registering 6
stand-alone Banks 39
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system requirements 6
Technical Publications 7
terminology 17
upgrading to Galaxy Plus Editors 7
using Bundles 35
Galaxy Configuration command 13, 109
Galaxy Configuration dialog box 109
Galaxy Keywords file 70
General Find dialog box 71
Get (Patch) from (Device) command 105
Get All Banks from (Device) command 30, 102
Get All Banks in Bundle command 31, 102
Get Bank from (Device) command 106
Graphical Data command 143
Guide editing 137

H
Hardware connections 14
Help
basic Galaxy help 24
device-specific help 23
Hide Windows in Multifinder preference 111

I
Ignore Name in Duplicate Check preference
47, 111
Initialize command 142
Installation
automatic 11
drag and drop 12
Editor Modules 11
Galaxy 10
Librarian Modules 10
using Galaxy Configuration 13

K
Keywords
adding to Find List 76
attaching to ALL Patches 67
attaching to Patches 65
attaching w/o closing dialog box 67
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complete list 149
custom 68
definition 65
deleting 69
detaching 67
finding 75
rearranging 67
removing from Find List 76
saving 70

L
LazyKeys 60
Learning Galaxy 3
Librarian Modules
drag and drop installation 12
installing automatically 11
installing w/Galaxy Configuration 13
overview 10
removing 14
updating 12
Libraries
copying entire Patch Banks 44
copying Patches between 49
copying Patches to 43
creating 41
creating randomized patch collections 126
definition 19
device selection 42
features 41
filling 43
saving 47
sending Patches 47
Library Sampler command 126
Library Window
anatomy 42
copying Patches to 43
Load/Send Menu 105
Get (Patch) from (Device) 105
Get Bank from (Device) 106
Play on Select 63
Send (Patch) to (Device) 38, 106
Send Bank to (Device) 106
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Index

Send on Select 38, 63, 107
w/Editor active 143
Loop Sequence command 63, 118

MouseKeys command 55
MouseKeys Window
anatomy 55
Multi option 58

M
Manuals
conventions 4
Technical Publications 7
using 3
Middle C is preference 112
MIDI
auditioning Patches w/MIDI controller 61
configuring devices 29
connecting cables 14
controlling sequencers from Galaxy 127
defining Middle-C 112
echo keyboard 118
enabling input devices 112
indicator light 59
panic button (all notes off) 118
parameter editing 136
sequencing patch edits 121
transferring data between applications 120
MIDI file
capturing 119
clearing 120
playing 63
MouseKeys
Auto option 58
channel/device selection 57
keyboard 55
LazyKeys 60
MIDI indicator 59
Multi option 58
opening 55
opening/closing 61
Repeat option 60
repeat rate 60
shifting octaves 56
sustain pedal 60
velocity range control 59
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N
Name Manager
using Galaxy to publish names 157
Names
auto-renaming 111
avoiding duplicates 45, 46
copying to text file 52
finding Patch Names 73
printing 52
New Bank command 39, 86
New Bank dialog box 39
New Bundle command 25, 85
New Library command 41, 87
New Library dialog box 41
Next Window command 128
No Duplicate Patches in Libraries preference
46, 110
Numerical editing 135

O
OMS
disabling 114
External ports 114
installing 9
selecting devices in Bundle Window 27
sending MIDI data to other apps 120
setting Device ID 28
sharing data 114
transport controls 127
using Galaxy w/compatible apps 157
using w/1.0 111
OMS MIDI Setup command 114
OMS Studio Setup command 113
OMS Transport command 127
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Index

On-Line Help
basic Galaxy help 24
device-specific help 23
Only Capture Dumps & Param Chgs 120
Opcode
contacting 6
Open command 87
Open MIDI File command 63, 117
Opening
Bank 88
Bundle 88
Library 88

P
Panic button 118
Parent Patches
automatically sending Child Patches 51
copying 50
definition 19
recognizing 50
w/stand-alone Banks 39
Paste Child Patch command
w/Editor active 142
Paste command 96
w/Editor active 142
Patch Info command 65, 99
Patch Information dialog box 66
Categories list 66
closing 69
Keywords list 66
Patch Menu 144
selecting a Patch 144
Store Current Edit 145
Patch Names
auto renaming 111
avoiding duplicates 45, 46
copying to text file 52
finding 73
printing 52
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Patches
Attached Patches 19
attaching keywords 65
auditioning w/computer keyboard 62
auditioning w/MIDI controller 61
auditioning w/MouseKeys 55
auditioning w/sequence 62
auto-renaming 111
blending patches to create new sounds 125
cataloging 65
Categories 66
Child Patches 19
comments (definition) 65
create controlled random sounds 123
creating random libraries 126
defining the "empty patch" 99
definition 17
deleting child patches 98
deleting duplicates 98
editing. See "Editing Techniques"
exporting to other applications 91
finding (General Find) 71
finding (Specific Find) 73
genesis of term 133
keywords (definition) 65
names in Library 45, 46
naming in Bank Window 38
Parent Patches 19
printing names 52
randomizing parameters 125
selecting in Bank Window 37
selecting w/Remote Control 113
sending automatically 38
sending from Library 47
sending individually 38
sending manually 38
sharing w/custom Keywords 70
shuffling parameters 124
viewing in Bank Window 36
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Index

Play Menu 117
All Notes Off (Panic) 118
Capture To MIDI File 119
Clear Capture 120
Echo Keyboard 61, 118
Loop Sequence 63, 118
MouseKeys 55
OMS Transport 127
Only Capture Dumps & Param Chgs 120
Open MIDI File 63, 117
Play on Parameter Change 146
Play on Select 118
Play Sequence 63, 118
Record Sequence 62, 117
Stop Sequence 63, 118
Use Omni Mode for Multi-Ch. Play 119
Play on Parameter Change command 146
Play on Select command 63, 118
Play Sequence command 63, 118
Pop-up menu editing 137
Preferences
Auto-rename uses 111
Hide Windows in Multifinder 111
Ignore Name in Duplicate Check 47, 111
Middle C is 112
No Duplicate Patches in Libraries 46, 110
Provide controller names for OMS 2.0 applications 111
Provide patch names for pre-OMS 2.0 applications 111
Window at Startup 110
Preferences command 110
Print command 52, 90
w/Editor active 141
Printing Patch Names 52
Provide controller names for OMS 2.0 applications preference 111
Provide patch names for pre-OMS 2.0 applications preference 111

Q
Quit command 94
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R
Record Sequence command 62, 117
Registering Galaxy 6
Remote Control
dialog box 113
uses 113
Remote Control command 113
Remove Device command 104
Repeat button 60

S
Save All command 128
Save And Make Current command 89
Save As command 89
Save As Template command 32, 104
Save command 30, 89
w/Editor active 141
Saving
Bundles 30
Libraries 47
Search Type options 81
Select All command 96
Select Device dialog box 25
Send (Patch) to (Device) command 38, 106
Send All Banks in Bundle command 32, 103
Send All Banks to (Device) command 31, 102
Send Bank to (Device) command 106
Send MIDI To command 120
Send on Select command 38, 63, 107
Sequence
looping 63
opening MIDI file 63
playing automatically 63
playing manually 62
recording 62
stopping 63
used for auditioning 62
Set Empty Patch command 99
Setups Menu 109
Enable Input Devices 61, 112
Galaxy Configuration 13, 109
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Index

OMS MIDI Setup 114
OMS Studio Setup 113
Preferences 110
Remote Control 113
Send MIDI To 120
Shade Two command 125
Show Numerical command 143
Shuffler command 124
Specific Find dialog box 73
closing 80
Stop Sequence command 63, 118
Store Current Edit command 145
Sub-Instruments
definition 37
System requirements 6

W
Where To Search options 80
Window at Startup preference 110
Windows Menu 127
Close All 128
Enter Editor 128
Exit to Galaxy 128
Next Window 128
Save All 128
selecting from all open windows 129

T
Technical Publications 7
Templates
creating "Find" templates 79
creating Bundle Templates 32
deleting Bundle Templates 33
using Bundle Templates 33
Testing Sounds command 62, 97
Toggle editing 136

U
UnCompare command 143
Undo command 95
w/Editor active 141
Use Omni Mode command 119

V
View By Icon command 28, 104
View By Name command 28, 104
Vision
controlling from Galaxy 127
sequencing patch edits 120
subscribing to Galaxy names 157
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